Adobe Premiere Pro kürzt Videodatei!?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Adobe Premiere Pro kürzt Videodatei!?

    Anzeige
    Hey Leute!

    Ich hab mal wieder ein ziemlich blödes Problem. Ich habe mit DXtory eine Gaming Aufnahme gemacht. Benutze das Programm eigentlich immer und seit ich so grob weiß, was ich da tue, habe ich auch eigentlich keine Probleme die Dinger danach mit Adobe Premiere Pro zu bearbeiten.

    Jetzt macht der allerdings was eigenartiges: Videodatei und Tonspur sind jeweils 39:03 Minuten lang im Explorer. Pack ich die beiden Videos in Premiere, ist die Audiodatei 39:03, die Videodatei allerdings 38:44 lang. Der schneidet die letzten Knapp 20 Sekunden einfach weg. Hab mit die Rohdatei angeschaut, da sind die zu sehen. Das passiert nur innerhalb von Premiere und ich weiß leider nicht woran es liegt, bzw. wie man das beheben kann.

    Kennt jemand diese Problematik, bzw. weiß, was ich tun kann, damit ich die vollen 39 Minuten hinbekomme?

    Besten Dank vorab und einen guten Wochenstart!
    Eure Kopfgeburt

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sem () aus folgendem Grund: Fremdlink entfernt.

  • Sorry hatte die Frage am Arbeits PC formuliert und keine Mediainfo zur Hand. Findet ihr im Spoiler.

    Spoiler anzeigen
    Allgemein
    Vollständiger Name : H:\DOSBox 2017-04-02 13-39-16-289.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 31,8 GiB
    Dauer : 39 min 5s
    Gesamte Bitrate : 117 Mb/s
    Originale Source-Form/Vertrieb durch : Video:UtVideo YUV422 BT.709 VCM Audio0:Lautsprecher (Realtek High Definition Audio) Audio1:Line (2- AG06/AG03)
    Kodierendes Programm : DxtoryCore ver2.0.0.136

    Video
    ID : 0
    Format : YUV
    Codec-ID : ULH2
    Codec-ID/Info : Ut Video Lossless Codec
    Codec-ID/Hinweis : Ut Video
    Dauer : 38 min 41s
    Bitrate : 110 Mb/s
    Breite : 640 Pixel
    Höhe : 480 Pixel
    Bildseitenverhältnis : 4:3
    Bildwiederholungsrate : 60,000 FPS
    ColorSpace : YUV
    ChromaSubsampling/String : 4:2:2
    Bits/(Pixel*Frame) : 5.969
    Stream-Größe : 29,7 GiB (93%)

    Audio #1
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 39 min 5s
    Bitraten-Modus : konstant
    Bitrate : 6 144 kb/s
    Kanäle : 2 Kanäle
    Samplingrate : 96,0 kHz
    BitDepth/String : 32 bits
    Stream-Größe : 1,68 GiB (5%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 99 ms (5,94 Video-Frames)

    Audio #2
    ID : 2
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 39 min 5s
    Bitraten-Modus : konstant
    Bitrate : 1 536 kb/s
    Kanäle : 1 Kanal
    Samplingrate : 48,0 kHz
    BitDepth/String : 32 bits
    Stream-Größe : 429 MiB (1%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 99 ms (5,94 Video-Frames)

  • Julien schrieb:

    Da gab es tatsächlich Probleme mit der Länge, die Videospur ist deutlich kürzer als die Audiospuren. Eventuell kannst du das durch ein simples Neumuxen mit VirtualDub schon beheben.
    Ok ich werde das mal versuchen. Auch wenn ich das noch nie gemacht habe und nicht mal weiß was muxen genau heißt. :D Ich versuch mich einfach mal dran. Wird schon schief gehen. Danke erstmal für den Tipp. Melde mich, wenns feddich ist.
  • Ach so, ich dachte das sei halbwegs bekannt. :P Du öffnest die Aufnahmedatei in VirtualDub, gehst über das Menü zu Audio und Video, stellst beides auf Direct Stream Copy und speicherst die Datei einfach unter einem anderen Namen ab. Damit wird ein neuer Container mit denselben Spuren geschrieben, und meine Hoffnung ist, dass dadurch Premiere die Datei besser einlesen kann.
  • Julien schrieb:

    Ach so, ich dachte das sei halbwegs bekannt. :P Du öffnest die Aufnahmedatei in VirtualDub, gehst über das Menü zu Audio und Video, stellst beides auf Direct Stream Copy und speicherst die Datei einfach unter einem anderen Namen ab. Damit wird ein neuer Container mit denselben Spuren geschrieben, und meine Hoffnung ist, dass dadurch Premiere die Datei besser einlesen kann.
    Nein sorry, bin leider doof. :D Alles klar ich probiers mal aus. Nochmals danke. :)
  • Okay, dann liegt es nicht am Header selbst, sondern da hat Dxtory vermutlich einfach Probleme gehabt, die Spuren synchron zu schließen. Jetzt gibt es wohl mehrere Wege, aber ich persönlich würde den einfachsten Weg wählen: Die erste Aufnahmedatei in MPC-HC öffnen, Dxtory starten, zur letzten Minute springen und MPC-HC mit Dxtory aufnehmen. So bekommst du die letzte Minute der kaputten Aufnahme noch mal separat und kannst sie in Premiere zur passenden Tonspur anlegen. ;)
  • De-M-oN schrieb:

    Bei unterschiedlichen Sampleraten ist es auch nicht überraschend das DXTory damit zu kämpfen hat die Dinger synchron zu halten.
    Ich habe zwar leider, aufgrund mangelnden Fachwissens, nicht wirklich n Plan was du mit Sampleraten meinst, aber ich habe meine komplette Reihe Siedler (über 100 Folgen inzwischen) ebenfalls über Dosbox aufgenommen, ohne derartige Probleme zu kriegen... :(
  • Damit sind die Abtastraten der Tonspuren gemeint, die du so eingestellt hast:

    Audio #1
    [...]
    Samplingrate : 96,0 kHz
    [...]
    Audio #2
    [...]
    Samplingrate : 48,0 kHz

    Wenn du mal alle Tonspuren auf dieselbe Hertzzahl bringst (entweder 44100 oder 48000), wird es einheitlicher. Trotzdem dürfte das nicht der Grund für dein Problem sein, da die Tonspuren ja identisch lang sind. Ich denke eher, dass Dxtory mit der DOSBox einen (hoffentlich) einmaligen Schluckauf hatte.
  • Julien schrieb:

    Damit sind die Abtastraten der Tonspuren gemeint, die du so eingestellt hast:

    Audio #1
    [...]
    Samplingrate : 96,0 kHz
    [...]
    Audio #2
    [...]
    Samplingrate : 48,0 kHz
    Wenn du mal alle Tonspuren auf dieselbe Hertzzahl bringst (entweder 44100 oder 48000), wird es einheitlicher. Trotzdem dürfte das nicht der Grund für dein Problem sein, da die Tonspuren ja identisch lang sind. Ich denke eher, dass Dxtory mit der DOSBox einen (hoffentlich) einmaligen Schluckauf hatte.
    Achso ok... Hab allerdings wie gesagt bei DosBox durchweg diese Einstellung und bei Siedler hats nie Probleme gemacht... vielleicht wäre es noch hilfreich zu sagen, dass ich die Folgen davor durchgehend aufgenommen habe... heißt 1 Datei für alle Folgen... der angesprochene Fehler trat lediglich in der letzten Folge auf, in der ich die Aufnahme beendet habe...
  • Ach es geht um Dosbox^^

    Hast bestimmt den Renderer idlen lassen bevor du die Aufnahme gestoppt hast, sprich nichts mehr aufm Bild passiert ist und der Encoder keine Frames mehr erhielt, weil nichts mehr am Bild passiert ist (0fps bei stillstehendem bild)

    Denn leider benutzt ihr ja alle die alte 0.74 dosbox + dem renderer mechanismus wo nur der anteil gerendert wird, der gerad gerendert werden muss.

    Hättest du zumindest noch mal vor Aufnahmestopp die Maus bewegt oder irgendwas zum rendern aufm bild produziert, hätte der Encoder wieder Frames erhalten und es wäre korrekter geschlossen worden.

    Würde dir anraten diese bei weitem bessere box zu nehmen:

    ykhwong.x-y.net/

    Läuft dann auch über Direct3D was auch die Aufnahme an sich schon wesentlich angenehmer macht. Der Render idle ist allerdings auch da noch drin, kannst du aber mit diesem pixelshader von mir rauswerfen:

    the-running-racers-clan.ath.cx/files/noidle.fx

    In der conf dann so eintragen:

    pixelshader=noidle.fx forced

    Die Sampleraten des Audios solltest du trotzdem mal angleichen.
    Aktuelle Projekte/Videos