OBS schluckt zu viel Arbeitsspeicher

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS schluckt zu viel Arbeitsspeicher

    Anzeige
    Guten Tagen,

    wie im Titel beschrieben verbraucht OBS zu viel Arbeitsspeicher, sodass die Spiele nicht mehr flüssig laufen. Dieses Problem tritt erst seit kurzem auf.
    Seit ich meinen pc neu aufgesetzt habe, habe ich Probleme mit OBS erst gab es fürchterliche Soundbugs, welche jetzt durch die Richtigen Einstellungen gelöst sind, allerdings scheint es nur mit utvideo zu funktionieren.

    Weiß jemand eine Möglichkeit, wie OBS weniger Ram verbraucht, ohne dabei den Video-Codierer zu ändern? Ich kenne mich mit dem Thema überhaupt nicht aus.

    Ich bin für jede Hilfe dankbar und hoffe auf eine schnelle Antwort.

    Einstellung in OBS unter Ausgabe: Aufnehmen

    Art: Benutzerdefinierte Ausgabe FFmpeg
    FFmpeg-Ausgabetyp : Ausgabe in Datei
    Container-Format: AVI
    Videobitrate: 2500
    Video-Codierer utvideo
    Audio Codierer: pcm-s16le

    Gibt es keine Möglichkeit die Auslastung des Arbeitsspeichers zu verringern?

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Arun ()

  • Spricht was gegen ein Aufnahmeprogramm das sich besser für verlustfreie Aufnahmen eignet als OBS?
    Die ffmpeg implementation von dem Teil hab ich bisher nur als extrem langsam erlebt.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Ne eigentlich nicht. Hatte mir schon Dxtory angeschaut, aber ich traue der Webseite irgendwie nicht^^
    Würde es allerdings lieber erstmal mit OBS noch weiter versuchen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Arun ()

  • Diese Einstellung finde ich nur, wenn ich unter Aufnehmen die Art auf normal stelle, allerdings kann Magix bei mir die mkv dateien nicht lesen, auch keine flv und die mp4 dateien haben krasse soundbugs^^. Ich teste jz mal mit x264 und einer Audiobitrate von 320.

    Scheint auch nicht zu funktionieren. Wenn ich das hochlade laggt es.^^

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Arun () aus folgendem Grund: Scheint auch nicht zu funktionieren. Wenn ich das hochlade laggt es.^^

  • RealLive schrieb:

    Du kannst x264 so fehlkonfigurieren, dass dir jeder Rechner überfordert ist. Stell mal auf ein schnelleres Preset. In OBS nennt sich das glaube ich Prozessorauslastung-Voreinstellung.
    Ja, das habe ich bereits gesehen, allerdings in OBS nur unter streamen und unter Aufnehmen finde ich das nur, wenn ich die Aufnahmeart auf normal stelle, allerdings lagt dann die mp4 in magix.
  • @Game8
    Stell lieber dein Profil auf High, statt auf Main.

    Sonst ist ja der x264 total Sinnbefreit ^^
    Du brauchst nämlich keine Features des Codecs beschränken. Theoretisch kannst du auch High444 nutzen. Das macht der aber automatisch glaub ich sofern du auf High eingestellt hast.
    Je besser das Profil, desto Uneingeschränkter kann x264 arbeiten, und desto bessere Ergebnisse kannst du bekommen zwecks Qualität des Bildes, Speichernutzung, Farben, Blockberechnung, und so weiter und sofort....

    Also nicht beschränken lassen.
    Und schon gar nicht für Normale Aufnahmen. Ihr büßt damit immer etwas ein was nicht sein muss.
  • Bei Ultrafast? Ernsthaft? Der Codec muss doch schon kaum was machen bei Ultrafast. xD

    Naja, wenn du ihn auf Main beschränkst, beschränkst du damit den Codec und büßt dafür auch Qualität ein.

    Ich würde wenn ich an deiner Stelle wäre lieber den Flaschenhals ausfindig machen woran das liegt.

    Zu schwacher Arbeitsspeicher? Eventuell zugemüllt?
    Oder kommt die Festplatte nicht hinterher, weil zu schwach?


    Ich kann dir aber auch aus Erfahrung sagen, da ich bei mir auch ein älteren Rechner habe, OBS mit x264 extrem langsam ist gegenüber richtige Lossless Codecs wie MagicYUV, UTVideo, etc.

    Weil x264 selbst mit Ultrafast immernoch ein Verlustcodec ist.

    Ich bin mir sicher, wenn du den CRF auf 1 stellst, geht alles viel flüssiger, weil der Codec dann kaum noch die Bilder behandeln muss.
    Die meiste Arbeit macht er nämlich bei der Komprimierung.
    Ideal wäre Lossless, da braucht er nämlich kaum noch Arbeitsspeicher, weil er damit keine Arbeit mehr hat die Bilder in Verlustmaterial umwandeln zu müssen.

    Kannst es ja mal testen ;D
  • Also bei mir ist ja das Problem, das die mp4 rohaufnahmen lagen wenn sie fertig sind und mit utvideo verbraucht obs 8gb ram. Ich hatte einen fehler in meinen Magix einstellungen, hoffentlich löst es das Problem mit den mp4 rohaufnahmen
  • Sagaras schrieb:

    Bei Ultrafast? Ernsthaft? Der Codec muss doch schon kaum was machen bei Ultrafast. xD

    Naja, wenn du ihn auf Main beschränkst, beschränkst du damit den Codec und büßt dafür auch Qualität ein.

    Ich würde wenn ich an deiner Stelle wäre lieber den Flaschenhals ausfindig machen woran das liegt.

    Zu schwacher Arbeitsspeicher? Eventuell zugemüllt?
    Oder kommt die Festplatte nicht hinterher, weil zu schwach?


    Ich kann dir aber auch aus Erfahrung sagen, da ich bei mir auch ein älteren Rechner habe, OBS mit x264 extrem langsam ist gegenüber richtige Lossless Codecs wie MagicYUV, UTVideo, etc.

    Weil x264 selbst mit Ultrafast immernoch ein Verlustcodec ist.

    Ich bin mir sicher, wenn du den CRF auf 1 stellst, geht alles viel flüssiger, weil der Codec dann kaum noch die Bilder behandeln muss.
    Die meiste Arbeit macht er nämlich bei der Komprimierung.
    Ideal wäre Lossless, da braucht er nämlich kaum noch Arbeitsspeicher, weil er damit keine Arbeit mehr hat die Bilder in Verlustmaterial umwandeln zu müssen.

    Kannst es ja mal testen ;D
    Ja ernsthaft, sobald ich das umstelle, kann ich zum beispiel Counter-Strike vollkommen vergessen, wieso auch immer. Die Aufnahme gleicht dann einer Diashow, aufgenommen wird auf eine SSD, da liegt das Problem nicht, mit den Einstellungen jetzt nehme ich sogar direkt auf ein NAS auf, wenn ich nicht direkt weiterverarbeiten sondern archivieren will. RAM ist mehr als genug da mit 16 GB, ich denke das irgendwo was mit dem Codec nicht passt. Habe zurzeit auch das Problem das beim schauen von Videos auf YouTube irgendwann das Video freezet, der Ton noch 10 bis 20 Sekunden weiterläuft, und sich dann der Tab aufhängt. Schätze da wird sich irgendwo was verhakt haben, ggf. muss ich den Rechner doch mal neu aufsetzen
    Viele Grüße,

    Christian
    __________________________________
    YouTube | Vid.me | Webseite | Aufnahme- und Sendeplan | Spieleliste | Daddel-United

  • Ich hatte ein ähnliches Problem mit OBS Studio. Mein Arbeitsspeicher lief nach und nach immer voller.
    Bei mir lag es daran, dass die Festplatte nicht mehr hinterher kam und daher alles im RAM zwischen gespeichert wurde und der dann rappel voll lief.

    Als ich zum Test auf die SSD aufgenommen habe, war alles wieder tutti.
    Hat vielleicht deine Festplatte einen Hau weg und hat keine ausreichend hohe Schreibrate mehr?
  • mhm, ich kenne mich da nicht aus^^. Wenn dem so wäre, dann müsste ich mir doch ne neue festplatte kaufen, oder?
    Oder gäbe es da noch andere Lösungswege?

    Vlt. wäre es auch noch wichtig zu erwähnen, dass dieses Problem erst aufgetaucht ist, als ich meinen PC das System zurückgesetzt habe mit einer Windows 10 funktion.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Arun ()