Spiele Aufnahme 60FPS lags/ruckler OBS/Shadow play

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Spiele Aufnahme 60FPS lags/ruckler OBS/Shadow play

    Anzeige
    Hallo Leute, ich habe ein Problem,dass ich seit Tagen selber nicht lösen kann. Es ist etwas Kompliziert


    Zum ersten Problem:
    Ich nehme Witcher 3 Haupsächlich mit OBS auf und stelle fest, wenn ich auf 720P@60fps einstelle und auch ich selber mit 60FPS spiel,dann sieht die Aufnahme viel flüssiger aus, als wenn ich ein paar FPS ingame höher gehe.
    Flüssig sieht es nur dann aus, wenn ich in-game 60FPS und 60FPS aufnehme oder 120FPS in-game spiele und 60FPS aufname.


    Will gerne 60FPS aufnehmen und gleichzeitig so etwa mit meinem Gsync monitor 80-100fps spielen. Das passiert nicht nur bei Witcher, sonder auch Fifa,Gothic oder BF1.


    Egal was ich einstelle=
    -Vsync an oder aus.
    -Witcher 3 Fenstermodus oder Vollbild.
    -Shadow play, Xsplit und obs Probiert.
    -PC auf Hochleistung eingestellt.
    -Meinen zweiten Monitor ausgeschaltet.
    -Defender ausgeschaltet.
    -Ganz egal ob ich mit NVENC oder CPU aufnehme oder auch Quicksync


    Keins diese genannten Experimente haben geholfen. Wie gesagt, immer wenn ich mit 60fps aufnehmen will und aber ich selber über 60FPS spielen will, ruckelt die Aufnahme,als wären es 30fps. Hab mir die Aufgabe etwas leichter gemacht und OBS vorschau auf dem zweiten bildschirm als Vollbild eingeblendet.
    Aber wenn ich 60FPS selber Spiele und auch auf 60 aufnehme.Sieht die aufnahme/Vorschau viel flüssiger aus.Allerdings gib es manchmal FPS-drops, die ich ingame nicht habe.


    Nun ist die frage,ist mein System bzw CPU zu schwach? Witcher wird etwa 44-60 % ausgelastet ausserhalb novigrad.
    Und nehme ja auch so auf, dass ich nicht auf hohe CPU Auslastung komme. Probiert hab ich auch auf NVENC. Da wird der CPU nur etwa 5% ausgelastet.Trotzdem gleiches Problem.


    Das zweite Problem:
    Ich sag mir ok dann nehme ich halt mit 60FPS auf und spiele mit genaue 60FPS/60HZ. Läuft alles superflüssig auch in der Aufnahme, aber mit häufigen Lags/ruckler. Das Problem habe ich mit OBS (alle versionen), Shadow play oder auch Xplit. Nur mit dem Programm mirillis action habe ich dieses Problem nicht. Im video sieht man eher nicht viele lags. Aber im normalfall habe ich viel mehr.


    (Siehe youtube video)



    OBS Aufnahme 720P@60 FPS
    1. Im Spiel: 60HZ/60 FPS= Flüssig
    1a. OBS zeigt flüssig aber mit paar lags


    2.Im Spiel: 120/144HZ 100FPS= Flüssig
    2a. OBS zeigt ruckler und sieht eher wie 30fps aus


    Was Brauche ich zur meinem ersten Problem, um das zu ermöglichen?
    Was kann ich tun zur meinem zweiten Problem?


    MEIN SYSTEM:
    Windows 10 64bit
    I7 4790
    16GB ram 1333
    250GB SSD +1TB HDD
    GTX 980 TI


    So hoffe habe nix vergessen und wäre für eine kleine Hilfe sehr dankbar
  • am besten ein logfile einer aufnahme posten (zu finden unter %appdata%/obs-studio/logs)

    1. gibt es viele probleme mit gsync monitoren, obs und 2. monitor der keine 120 hz hat - liest man im obs forum recht häufig (bin da sehr aktiv)
    2. gibt es momentan probleme mit dem aktuellen windows update (creators update) - ein patch kommt mit der nächsten version

    schau im game capture ob du den haken bei der limitierung drin hast.

    allgemeine Empfehlung der obs entwickler ist es die gleichen fps zu verwenden wie der monitor

    hab grad mal in dein video reingeguckt. Du solltest immer limitieren, weil wenn deine Grafikkarte am limit läuft hat sie keine power mehr die obs szene zu rendern (das sieht man auch im log) - kleiner hintergrund die szene kann ja mehr enthalten als nur das game capture (für streams) zb overlays, facecam, text etc) - die szene wird von der grafikkarte berechnet ebenso die skalierung (sofern deine szene kleiner/größer ist als das game)

    die mini lags können auch durch eine skalierung kommen, gerade wenn du lanczos als filter eingestellt hast und im bild sehr viele details sind (viele bäume mit detailierten blättern zb)

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Schauerland ()

  • Schauerland schrieb:

    am besten ein logfile einer aufnahme posten (zu finden unter %appdata%/obs-studio/logs)

    1. gibt es viele probleme mit gsync monitoren, obs und 2. monitor der keine 120 hz hat - liest man im obs forum recht häufig (bin da sehr aktiv)
    2. gibt es momentan probleme mit dem aktuellen windows update (creators update) - ein patch kommt mit der nächsten version

    schau im game capture ob du den haken bei der limitierung drin hast.

    allgemeine Empfehlung der obs entwickler ist es die gleichen fps zu verwenden wie der monitor

    hab grad mal in dein video reingeguckt. Du solltest immer limitieren, weil wenn deine Grafikkarte am limit läuft hat sie keine power mehr die obs szene zu rendern (das sieht man auch im log) - kleiner hintergrund die szene kann ja mehr enthalten als nur das game capture (für streams) zb overlays, facecam, text etc) - die szene wird von der grafikkarte berechnet ebenso die skalierung (sofern deine szene kleiner/größer ist als das game)

    die mini lags können auch durch eine skalierung kommen, gerade wenn du lanczos als filter eingestellt hast und im bild sehr viele details sind (viele bäume mit detailierten blättern zb)

    Danke erstmal für eure Anworten

    So..
    Problem 2 hat sich gelöst..
    Problem 1 besteht noch...

    Es lag tatsächlich an meinem 144Hz Gsync Monitor. Hatte zwar vor paar Tagen auch nur den angeschlossen, um die lags zu testen, war aber nicht genau genug.
    Nun habe ich gerade( bevor ihr geantwortet habt^^) getestet und NUR den 4k Monitor angeschlossen und nehme dann mit Shadowplay auf.
    Und sehe noch keinen einzigen lagg ;)
    Nur bei OBs gab es ein paar.

    -Wie meinst du das mit Limitierung? Meinst du bei Gameaufnahme " Limitiere FPS der Aufnahme"? Da hab ich kein haken aber auch schon Probiert gehabt.
    -Gleiche FPs verwenden wie der Monitor? wie ist das gemeint? Wenn mein Monitor 144hz kann und ich mit 144FPS spiele dann kann ich doch nicht mit 144FPS aufnehmen O.o
    -Mich würde sehr interessieren, ob es möglich wäre,wenn ich mit 60FPs obs aufnehme und witcher 3 zb 80-100fps habe,ob dann Aufname/stream flüssig läuft. Wenn ich selber 60fps spiele und 60 aufnehme dann sieht man ja echte 60fps.über 60fps spielen sieht man keine 60fps mehr....

    Oh man, ist das peinlich ^^ dachte ihr meint Creative update. Hab erst gerade im google creators update zufällig gefunden.
    Und da hab ich festgestellt,dass der bei meinem System nicht drauf ist.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von hypernova ()

  • Anzeige
    Wie gesagt poste mal das Logfile.

    Shadowplay sollte immer lagfrei sein, da es genau das aufnimmt was du siehst.

    Mit limitierung meinte ich den Haken, ja

    Also die Entwickler empfehlen gleiche fps beim Aufnahme monitor, monitoring monitor (wo obs läuft) und spiel (fps lock)

    ich wette du hast rendering lags aber das sieht man im Log, deswegen poste das bitte mal :)
  • Schauerland schrieb:

    Shadowplay sollte immer lagfrei sein, da es genau das aufnimmt was du siehst.
    naja mit dem doofen creators update von windows 10 hat wohl selbst das irgendwelche probleme, kam aber neue GFE version, vllt behebt sie ja was.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • 14:59:04.350: CPU Name: Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz
    14:59:04.350: CPU Speed: 3600MHz
    14:59:04.350: Physical Cores: 4, Logical Cores: 8
    14:59:04.350: Physical Memory: 16329MB Total, 14196MB Free
    14:59:04.350: Windows Version: 10.0 Build 14393 (revision: 1066; 64-bit)
    14:59:04.350: Running as administrator: false
    14:59:04.350: Aero is Enabled (Aero is always on for windows 8 and above)
    14:59:04.350: Portable mode: false
    14:59:04.361: OBS 18.0.1 (64bit, windows)
    14:59:04.361: ---------------------------------
    14:59:04.361: ---------------------------------
    14:59:04.361: audio settings reset:
    14:59:04.361: samples per sec: 48000
    14:59:04.361: speakers: 2
    14:59:04.362: ---------------------------------
    14:59:04.362: Initializing D3D11..
    14:59:04.362: Available Video Adapters:
    14:59:04.364: Adapter 1: NVIDIA GeForce GTX 980 Ti
    14:59:04.364: Dedicated VRAM: 2105212928
    14:59:04.364: Shared VRAM: 4266334208
    14:59:04.364: output 1: pos={0, 0}, size={2560, 1440}, attached=true
    14:59:04.366: Loading up D3D11 on adapter NVIDIA GeForce GTX 980 Ti (0)
    14:59:04.823: D3D11 loaded sucessfully, feature level used: 45056
    14:59:05.409: ---------------------------------
    14:59:05.409: video settings reset:
    14:59:05.409: base resolution: 2560x1440
    14:59:05.409: output resolution: 1280x720
    14:59:05.409: downscale filter: Lanczos
    14:59:05.409: fps: 60/1
    14:59:05.409: format: NV12
    14:59:05.410: Audio monitoring device:
    14:59:05.410: name: Standard
    14:59:05.410: id: default
    14:59:05.410: ---------------------------------
    14:59:05.411: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
    14:59:05.412: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
    14:59:05.413: [AMF Encoder] Unable to load 'amfrt64.dll', error code 126.
    14:59:05.419: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
    14:59:05.420: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libEGL.dll' not found, loading of module failed
    14:59:05.420: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
    14:59:05.420: Failed to load 'en-US' text for module: 'obs-browser.dll'
    14:59:05.420: [browser_source: 'Version: 1.29.0']
    14:59:05.422: NVENC supported
    14:59:05.453: VLC found, VLC video source enabled
    14:59:05.457: No blackmagic support
    14:59:05.634: ---------------------------------
    14:59:05.634: Loaded Modules:
    14:59:05.635: win-wasapi.dll
    14:59:05.635: win-mf.dll
    14:59:05.635: win-dshow.dll
    14:59:05.635: win-decklink.dll
    14:59:05.635: win-capture.dll
    14:59:05.635: vlc-video.dll
    14:59:05.635: text-freetype2.dll
    14:59:05.635: rtmp-services.dll
    14:59:05.635: obs-x264.dll
    14:59:05.635: obs-vst.dll
    14:59:05.635: obs-transitions.dll
    14:59:05.635: obs-text.dll
    14:59:05.635: obs-qsv11.dll
    14:59:05.635: obs-outputs.dll
    14:59:05.635: obs-filters.dll
    14:59:05.635: obs-ffmpeg.dll
    14:59:05.635: obs-browser.dll
    14:59:05.635: image-source.dll
    14:59:05.635: frontend-tools.dll
    14:59:05.635: enc-amf.dll
    14:59:05.635: coreaudio-encoder.dll
    14:59:05.635: ==== Startup complete ===============================================
    14:59:05.637: All scene data cleared
    14:59:05.637: ------------------------------------------------
    14:59:05.667: WASAPI: Device 'Lautsprecher (Sound Blaster Z)' initialized
    14:59:05.673: WASAPI: Device 'Mikrofon (3- USB Audio CODEC )' initialized
    14:59:05.673: [Media Source 'Medienquelle 7 Intro']: settings:
    14:59:05.673: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/The Witcher 3 Wild Hunt - Rage and Steel Trailer.mp4
    14:59:05.673: input_format: (null)
    14:59:05.673: is_looping: no
    14:59:05.673: is_forcing_scale: yes
    14:59:05.673: is_hw_decoding: yes
    14:59:05.673: is_clear_on_media_end: yes
    14:59:05.673: restart_on_activate: yes
    14:59:05.674: [Media Source 'Medienquelle 4 1.5']: settings:
    14:59:05.674: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/1.5+.flv
    14:59:05.674: input_format: (null)
    14:59:05.674: is_looping: no
    14:59:05.674: is_forcing_scale: yes
    14:59:05.674: is_hw_decoding: yes
    14:59:05.674: is_clear_on_media_end: yes
    14:59:05.674: restart_on_activate: yes
    14:59:05.674: [Media Source 'Medienquelle 3 1.4']: settings:
    14:59:05.674: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/1.4+.flv
    14:59:05.674: input_format: (null)
    14:59:05.674: is_looping: no
    14:59:05.674: is_forcing_scale: yes
    14:59:05.674: is_hw_decoding: yes
    14:59:05.674: is_clear_on_media_end: yes
    14:59:05.674: restart_on_activate: yes
    14:59:05.674: [Media Source 'Medienquelle 2 1.2']: settings:
    14:59:05.674: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/1.2+.flv
    14:59:05.674: input_format: (null)
    14:59:05.674: is_looping: no
    14:59:05.674: is_forcing_scale: yes
    14:59:05.674: is_hw_decoding: yes
    14:59:05.674: is_clear_on_media_end: yes
    14:59:05.674: restart_on_activate: yes
    14:59:05.674: [Media Source 'Medienquelle 1 1.0']: settings:
    14:59:05.674: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/1.0+.flv
    14:59:05.674: input_format: (null)
    14:59:05.674: is_looping: yes
    14:59:05.674: is_forcing_scale: yes
    14:59:05.674: is_hw_decoding: yes
    14:59:05.674: is_clear_on_media_end: yes
    14:59:05.674: restart_on_activate: yes
    14:59:05.676: Failed to open file 'C:/Users/Bloodwyn/Pictures/maxresdefault.jpg': No such file or directory
    14:59:05.676: gs_image_file_init: Failed to load file 'C:/Users/Bloodwyn/Pictures/maxresdefault.jpg'
    14:59:05.676: [image_source: 'Pause'] failed to load texture 'C:/Users/Bloodwyn/Pictures/maxresdefault.jpg'
    14:59:05.676: [Media Source 'Medienquelle 6 1.5 Epic']: settings:
    14:59:05.676: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/(1.5) Epic.flv
    14:59:05.676: input_format: (null)
    14:59:05.676: is_looping: no
    14:59:05.676: is_forcing_scale: yes
    14:59:05.676: is_hw_decoding: yes
    14:59:05.676: is_clear_on_media_end: yes
    14:59:05.676: restart_on_activate: yes
    14:59:05.676: [Media Source 'Medienquelle 5 1.4 Epic']: settings:
    14:59:05.676: input: D:/Backup/the_witcher_3_wild_hunt_game_of_the_year_edition_game/Mods + BAckup daten/(1.4) Epic.flv
    14:59:05.676: input_format: (null)
    14:59:05.676: is_looping: no
    14:59:05.676: is_forcing_scale: yes
    14:59:05.676: is_hw_decoding: yes
    14:59:05.676: is_clear_on_media_end: yes
    14:59:05.676: restart_on_activate: yes
    14:59:05.745: adding 21 milliseconds of audio buffering, total audio buffering is now 21 milliseconds
    14:59:07.722: Switched to scene 'Szene 1'
    14:59:07.724: ------------------------------------------------
    14:59:07.724: Loaded scenes:
    14:59:07.724: - scene 'Szene 1':
    14:59:07.724: - source: 'Fensteraufnahme' (window_capture)
    14:59:07.724: - source: 'Bildschirmaufnahme' (monitor_capture)
    14:59:07.724: - source: 'Witcher 3' (game_capture)
    14:59:07.724: - source: 'Medienquelle 7 Intro' (ffmpeg_source)
    14:59:07.724: - source: 'Medienquelle 6 1.5 Epic' (ffmpeg_source)
    14:59:07.724: - source: 'Medienquelle 5 1.4 Epic' (ffmpeg_source)
    14:59:07.724: - source: 'Medienquelle 4 1.5' (ffmpeg_source)
    14:59:07.724: - source: 'Medienquelle 3 1.4' (ffmpeg_source)
    14:59:07.724: - source: 'Medienquelle 2 1.2' (ffmpeg_source)
    14:59:07.724: - source: 'Medienquelle 1 1.0' (ffmpeg_source)
    14:59:07.724: - source: 'Pause' (image_source)
    14:59:07.724: - source: 'Spielaufnahme' (game_capture)
    14:59:07.724: ------------------------------------------------
    14:59:19.616: adding 21 milliseconds of audio buffering, total audio buffering is now 42 milliseconds
  • Schauerland schrieb:

    Wie gesagt poste mal das Logfile.

    Shadowplay sollte immer lagfrei sein, da es genau das aufnimmt was du siehst.

    Mit limitierung meinte ich den Haken, ja

    Also die Entwickler empfehlen gleiche fps beim Aufnahme monitor, monitoring monitor (wo obs läuft) und spiel (fps lock)

    ich wette du hast rendering lags aber das sieht man im Log, deswegen poste das bitte mal :)
    Ah ok also mein 4k Monitor kann nur 60Hz also läuft mit Vsync bis 60FPS und nehme auch mit 60FPS auf.
    Und das ganze sieht ja auch flüssig aus.

    Wenn ich exakt 120FPS ingame habe und mit 60FPS aufnehme läuft die Aufnahme auch Flüssig.
    Bemerkt habe ich auch wenn ich exakt 2x,3x,4fache 60FPS Spiele also zb 240FPS spiele und 60FPS aufnehme dann sieht es auch flüssig aus.
  • das log sagt leider nix über die aufnahme aus, entweder ist der teil abgeschnitten oder es ist nicht von einer aufnahme.

    Also du skalierst schon mal von 1440p auf 720p runter mit Lanczos

    sofern du kein fps limit oder vsync drin hat, wird deine karte am limit laufen (100% auslastung) und die szene kann nicht mehr in echtzeit runter gerechet (skaliert) werden.

    das kannst du immer schön sehen wenn die fps anzeige in OBS (unten im footer) einbricht

    Wenn du also eh ein 720p video hast würde ich auch in 720p spielen damit du schon mal nicht skalieren musst oder in 1440p aufnehmen
  • Schauerland schrieb:

    das log sagt leider nix über die aufnahme aus, entweder ist der teil abgeschnitten oder es ist nicht von einer aufnahme.

    Also du skalierst schon mal von 1440p auf 720p runter mit Lanczos

    sofern du kein fps limit oder vsync drin hat, wird deine karte am limit laufen (100% auslastung) und die szene kann nicht mehr in echtzeit runter gerechet (skaliert) werden.

    das kannst du immer schön sehen wenn die fps anzeige in OBS (unten im footer) einbricht

    Wenn du also eh ein 720p video hast würde ich auch in 720p spielen damit du schon mal nicht skalieren musst oder in 1440p aufnehmen
    Kann ja den log von gestern hier Posten.(ist aber lang)

    Vsync ist On. Wenn ich ausschalte dann habe ich 100% fps unbegrenzt. Dann habe ich etwa über 100FPS und sieht sogar ohne vsync/gsync sogar bei mir sehr ruckelig aus.

    Ich kann doch nicht mit 720P spielen. Das geht doch nicht :cursing: :cursing: :D
  • Schauerland schrieb:

    lade das log am besten bei pastebin hoch oder so.

    du kannst auch in 1440p aufnehmen wenn deine Platte schnell genug ist.
    Die GTX 980Ti schafft das locker über nvenc. sogar lossless wenn du willst.
    Ja das weis ich schon. Glaube schaffe 2k lossless.
    Nur ich nehme mit dieser einstellung auf, was ich beim Streamen verwenden werde.

    Da ich maximal bei twisch 5000kb verwende und über nvenc die quali schlechter ausschaut als beim x264, kann ich nicht über 720P streamen.

    Mit meinem CPU schaffe ich 720P@60fps/5000KB gerade mal auf "very fast". Und witcher braucht bei 60FPS maximal 50-60 CPU Auslastung.
    Meinst du mit einem i7 6800K oder AMD 1700X wäre ich besser oder viel besser Bedient? Wenn du dich damit auskennst.

    Übrigens weis ich immer noch nicht warum, dieses Problem mit Gsync Monitor passiert, wenn ich den Creators Update nicht installiert habe.
    Habe den Heute früh am Morgens den Update genommen.
    Hab gestern nochmal genauer dieses Mirillis Action Aufnahmeprogramm mit meinem Gsync-Monitor wieder getestet und da kommt kein 4-10 sekunden stottern/laggs vor. Verstehe das nicht wirklich...
    Möchte schon ganz gerne mein Gsync-Monitor nutzen und nicht zur seite legen :(

    pastebin.com/RRA5mEhj

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von hypernova ()

  • hypernova schrieb:

    Nur ich nehme mit dieser einstellung auf, was ich beim Streamen verwenden werde.
    Du kannst dir ja verschiedene Profile mit entsprechenden Einstellungen anlegen in OBS. Eins für Twitch, eins für Aufnahmen, ...


    Und wie gesagt, du kannst auch einstellen, dass nur beim Streamen die Auflösung runterskaliert wird:

    AKTUELLE PROJEKTE
    12 Uhr: Crysis 2 [BLIND]
    15 Uhr: Star Wars: Knights of the Old Republic II
    18 Uhr: FarCry 3


  • Schauerland schrieb:

    Also du hast ab und zu mal kleinere lags im rendering aber nicht ganz so dramatisch:

    Quellcode

    1. Number of lagged frames due to rendering lag/stalls: 22 (0.2%)
    du kannst auch in 720p streamen und parallel in 1440p aufnehmen
    streamen kannst du dann mit x264 und aufnehmen mit nvenc - geht alles :)
    Ja genau, so hatte ich auch vor.Oder besser gesagt,so sollte man auch machen.
    Streamen= x264
    Aufnehmen= Nvenc oder Quicksync.

    Genau das mit dem Profile habe ich eigentlich noch nicht gemacht weil ich ständig einstellungen ändere.
    Die laggs/ stottern sind nicht wirklich dramatisch. Aber ich bin da etwas sensible was das angeht. Manchmal sind es wenige und manchmal alle 5 secunden.

    Müsste mal weiter herumtesten vieleicht läuft es ja beim streamen viel besser als Aufnahme.Bisher hab ich nur Aufgenommen um die ruckler zu testen.

    Finde auch wirklich sehr nett und hilfreich, dass du mir hilfst.Danke :thumbup: