Movie Maker produziert Artefakte

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Movie Maker produziert Artefakte

    Anzeige
    Hallo zusammen,

    ich hoffe, hier kann mir jemand weiter helfen. Zum Aufnehmen meiner Let's plays benutze ich OBS und das klappt auch soweit ganz gut. Anschließend lade ich das Video zum Bearbeiten in den Movie Maker. Beim Exportieren des fertigen Videos wird dieses erstens extrem viel größer als das Originalvideo, zweitens zeigen sich im exportierten Film später Artefakte (stark verpixelte Bereiche etc.), die im Original nicht zu sehen sind.

    Ich habe schon alles Mögliche bei den Exporteinstellungen ausprobiert, aber irgendwie finde ich nicht heraus, woran es liegt. Bei den meisten Spielen ist es kein großes Problem, da ich überwiegend wenig Grafik-intensive Sachen spiele, aber bei Spielen wie CS:GO oder Motorsport Manager etc. treten die besagten Probleme auf und es sieht recht störend im Video aus.

    Hat jemand Erfahrung mit dem MovieMaker? Kann jemand ein besseres (vorzugsweise kostenloses) Programm als Alternative vorschlagen?
    Mit dem Tool möchte ich i.d.R. Tonspuren austauschen / bearbeiten, sowie den Film schneiden können.

    Danke schonmal.
  • CondorDrake schrieb:

    Beim Exportieren des fertigen Videos wird dieses erstens extrem viel größer als das Originalvideo
    Wenn ich das lese vermute ich, dass du OBS nicht wirklich optimal eingestellt hast und es bereits stark verlustbehaftet aufnimmt. Schwächen im Workflow summieren sich irgendwann soweit auf, dass sie sichtbar werden.

    CondorDrake schrieb:

    Kann jemand ein besseres (vorzugsweise kostenloses) Programm als Alternative vorschlagen?
    Shotcut.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • RealLiVe schrieb:

    CondorDrake schrieb:

    Beim Exportieren des fertigen Videos wird dieses erstens extrem viel größer als das Originalvideo
    Wenn ich das lese vermute ich, dass du OBS nicht wirklich optimal eingestellt hast und es bereits stark verlustbehaftet aufnimmt. Schwächen im Workflow summieren sich irgendwann soweit auf, dass sie sichtbar werden.

    CondorDrake schrieb:

    Kann jemand ein besseres (vorzugsweise kostenloses) Programm als Alternative vorschlagen?
    Shotcut.
    Wie gesagt, das Originalvideo, welches mit OBS aufgenommen wird, ist völlig in Ordnung, dort treten die Bildfehler nicht auf. Erst nach der weiteren Bearbeitung und Export mit Movie Maker.

    Falls es weiter hilft, ich nehme im OBS 1080p mit 60fps auf.

    Shotcut werde ich mir mal anschauen, danke.
  • CondorDrake schrieb:

    Wie gasgt... am OBS liegt es nicht -> die Videos, die aus OBS aus purzeln sind einwandfrei...
    Mag sein, aber wenn du dort Lossy aufnimmst und für dich rein optisch in Ordnung sind, sind die dennoch verlustbehaftet.
    Somit machst du beim rendern von verlustbehaftetn Material nochmal das gleiche.

    Nimmst du in OBS mit NVENCH oder x.264 Software encoder auf, wie laufen die Bitraten, VBR, CRF, CQP???
    **in die Glaskugel schaut**
  • IronballzZ schrieb:

    CondorDrake schrieb:

    Wie gasgt... am OBS liegt es nicht -> die Videos, die aus OBS aus purzeln sind einwandfrei...
    Mag sein, aber wenn du dort Lossy aufnimmst und für dich rein optisch in Ordnung sind, sind die dennoch verlustbehaftet.Somit machst du beim rendern von verlustbehaftetn Material nochmal das gleiche.

    Nimmst du in OBS mit NVENCH oder x.264 Software encoder auf, wie laufen die Bitraten, VBR, CRF, CQP???
    **in die Glaskugel schaut**
    Ähm quark, moment, ich hab grad bei Streaming geschaut. Bei Video ist folgendes eingestellt:

    CQP 23, Encoder NVENC H.264
  • Schmeiß Movie Maker runter, das ist schrott.
    Auf Steam gibts im Sale immer mal wieder günstig Movie Studio Platinum 13, was sehr gut ist für LPs. Wenn du kein Schnittprogramm kaufen willst, dann sind Shotcut und Hitfilm (ich glaub 4.2?) kostenlose Alternativen.

    Mit lossy Aufnahmen kann man auch gute Video machen, lass dir da nichts einreden, mach ich genauso. Deine Einstellungen solltest du trotzdem nochmal überarbeiten.

    Ich würde das Preset auf Qualität stellen (das war doch für Quali u. Speed, bin mir da grad nciht sicher),
    Profile auf High,
    two pass encoding raus (dafür CQP für bessere Quali einstellen),
    color format auf i420 und color space auf 709. Bei dem Farbbereich musst du gucken was da am besten für dich ist, für mich ist "Voll" besser, weil darum halt und so.

    Der NVENC ist sowieso nicht so gut, darum solltest du wenn überhaupt die Einstellungen so setzen das du die beste Quali aus dem Chip holst.
    Um zu gucken ob du den Chip überlastet machst du am besten Testaufnahmen, mit möglichst viel Bildveränderungen für maximale Auslastungen (damits später nicht ruckelt in den Aufnahmen), lässt nebenbei GPU-Z laufen (dort ist bei NVIDIA Karten ein ein extra Sensor für Videoencoder Auslastung und/oder stellst den MSI AB so ein (ich erklär das aber nicht) das die Auslastung auch im im OSD angezeigt wird.
    Dann versuchst du deine Einstellungen so zu setzen das die Chipauslastung im 90% Bereich bleibt und sich nicht auf 99% festklammert, dann ruckelts im Video.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dragobee ()

  • Dragobertel schrieb:

    lass dir da nichts einreden
    Gibt zum Glück genug Guides hier im tollen LPF von Leuten die von der Materie was verstehen.
    Am besten schaust du nochmals hier rein: https://www.letsplayforum.de/index.php/Thread/166024-OBS-Studio-Verlustfreie-Aufnahme-Sammelthread/?pageNo=1



    Dragobertel schrieb:

    coler format auf i420 und color space auf 709. Bei dem Farbbereich musst du gucken was da am besten für dich ist, für mich ist "Voll" besser, weil darum halt und so.
    Als Color Format würde ich definitiv NV12 setzen, weil besser und so.
    Aber dazu wird/kann dir sicher @Sagaras was sagen. (Duckt sich weg) :)

    Aber zu deiner Frage welches Schnittprogramm, die gibts wie Sand am Meer, wobei jeder seine Favoriten hat und dabei andere Meinungen nicht akzeptiert. Sicher ist Premiere eines der besten mit, aber das will auch bezahlt werden. Für ein gutes Mittelding schau dir mal Magix Video Deluxe an.

    Aber wie gesagt da gibt es viele und da muss man für sich selber entscheiden, was gebe ich aus, und was reicht mir. Vegas, Premiere und Co wollen halt bezahlt werden.
  • Dragobertel schrieb:

    color format auf i420 und color space auf 709. Bei dem Farbbereich musst du gucken was da am besten für dich ist, für mich ist "Voll" besser, weil darum halt und so.
    NV12 ist performanter als i420.
    Full Range hat bei YUV Video nichts zu suchen. Ist unüblich und macht dir auch schnell probleme mit der Farbdarstellung.
    Verlustfreie Aufnahme ist für NVEnc weniger Systembelastung als verlustkomprimiert.
    Auch bei NVEnc muss OBS noch ins Spiel hooken, weshalb man den Haupt FPS Verlust - das hooking - nicht umgehen kann. Die Capture APIs hat Nvidia für Drittsoftware gesperrt, damit die gute Performance dem Shadowplay (und demnach künstlich) vorbehalten bleibt
    Auch sollte man im NVInspector abschalten das die Grafikkarte den VRAM auf Leistungsmodus 2 runtertaktet, sobald NVEnc von Drittsoftware genutzt wird.
    Aktuelle Projekte/Videos


  • Friesenstahl schrieb:

    De-M-oN schrieb:

    Auch sollte man im NVInspector abschalten das die Grafikkarte den VRAM auf Leistungsmodus 2 runtertaktet, sobald NVEnc von Drittsoftware genutzt wird.
    Wo genau stellt man diese Option im Inspector um ? Ich würde das gerne machen, kann es aber nicht finden. Bin vermutlich blind ;)
    Würde mich auch interessieren!

    Danke schonmal für Eure Vorschläge, die ja z.T. auch ziemlich auseinander gehen. Ich werde mal mir Euren Tipps rumprobieren.
  • @De-M-oN Danke :)
    Wusste gar nicht dass man das einstellen kann.

    Bin aber eh auf dem Weg mir ne GTX 1080 zu holen - da merkt man das runtertakten vermutlich nicht.

    Generell habe ich das Gefühl dass es sich nur auf der rendering der Szene auswirkt da man mit NVENC mehr render lags hat als mit x264

    Update: Hab den Punkt nicht, trotz aktivierung der versteckten optionen :/
    scheint also die GTX 970 nicht zu betreffen...

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Schauerland ()

  • Ich benutze eine GTX 1060 und hab das eben mal ausprobiert, leider ohne Erfolg. Die Artefakte tauchen immer noch im Video auf, sobald ich das mit OBS aufgenommene Video in MovieMaker bearbeite und dort wieder exportiere.

    Um mal zu beschreiben, was ich damit meine:



    In dem Video, bei 0:03, also ganz am Anfang wo die Flash-Granate fliegt, sieht man, dass das Bild plötzlich extrem verpixelt wird. Das Ganze passiert später im Video auch während des normalen Gameplay noch ein paar Mal. Das ist also kein permanenter Effekt, der durchgängig im ganzen Video auftritt, sondern passiert an einigen Stellen ohne für mich erkennbaren Grund.