Trotz korrekter Einstellungen, Schlieren im Video

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Trotz korrekter Einstellungen, Schlieren im Video

    Anzeige
    Hallo Leute,

    seit ein paar Wochen nehme ich bereits TTT auf und nehme aber nun schon seit 1 Woche in 50 FPS auf. Die ersten Folgen konnte ich ohne diverse Bildstörungen oder Schlieren rendern bzw. encodieren, doch bei einer der neuesten Folgen auf 50 FPS, hab ich plötzlich Schlieren im Video, auch wenn ich alle Einstellungen korrekt getätigt habe. Also sowohl bei Sony Vegas als auch bei MeGUI und beim Sagaras Scriptmaker.

    Zur Info:
    Die Rohdateien werden erstmal in Sony Vegas entsprechend bearbeitet, geschnitten etc.. Danach render ich erstmal die Tonspur als .flac Datei. Dann wird der Frameserver gestartet und das dadurch erstellte Video in den Scriptmaker reingeschoben. Dort erstelle ich dann das Script, das ich dann nur noch in MeGUI reinpacke um dann den Encodierungs-Vorgang zu starten. Ich habe bisher immer nur die FPS in Sony Vegas angepasst und hatte bisher nie Probleme. Jetzt habe ich aber bei einer Folge, die ich rendern möchte, so seltsame Schlieren drin, wenn ich mich im Video bewege.
    Wie gesagt, ist in Sony Vegas alles richtig eingestellt mit Auflösung, FPS u.s.w. Habe auch das Resampling deaktiviert.

    Kann mir jemand sagen, woran das noch liegen könnte?

    Hier mal die MediaInfo. Vielleicht ist sie hilfreich:

    Spoiler anzeigen

    Allgemein
    Vollständiger Name : D:\Aufnahmen\hl2 18-07-2017 16-28-37.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    Format-Profil : OpenDML
    Dateigröße : 27,9 GiB
    Dauer : 32 min 45s
    Gesamte Bitrate : 122 Mb/s

    Video
    ID : 0
    Format : FICV
    Codec-ID : FICV
    Dauer : 32 min 45s
    Bitrate : 121 Mb/s
    Breite : 1 280 Pixel
    Höhe : 720 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 50,000 FPS
    Bits/(Pixel*Frame) : 2.616
    Stream-Größe : 27,6 GiB (99%)

    Audio
    ID : 1
    Format : PCM
    Format-Einstellungen für Endianess : Little
    Format-Einstellungen für Sign : Signed
    Codec-ID : 1
    Dauer : 32 min 45s
    Bitraten-Modus : konstant
    Bitrate : 1 411,2 kb/s
    Kanäle : 2 Kanäle
    Samplingrate : 44,1 kHz
    BitDepth/String : 16 bits
    Stream-Größe : 331 MiB (1%)
    Ausrichtung : Ausgerichtet an Interleaves
    Interleave, Dauer : 10 ms (0,50 Video-Frame)


    Und hier die MediaInfo der fertig gerenderten Videodatei:

    Spoiler anzeigen

    Allgemein
    UniqueID/String : 250125897794977516236033093295035161377 (0xBC2C7EE275D17EFFB10281B77AB49B21)
    Vollständiger Name : D:\Fertig gerendert\Let's Play Together Trouble in Terrorist Town (TTT) #23 (Gameplay).mkv
    Format : Matroska
    Format-Version : Version 4 / Version 2
    Dateigröße : 4,77 GiB
    Dauer : 32 min 7s
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 21,3 Mb/s
    Kodierungs-Datum : UTC 2017-07-24 00:57:27
    Kodierendes Programm : mkvmerge v9.9.0 ('Pick Up') 64bit
    verwendete Encoder-Bibliothek : libebml v1.3.4 + libmatroska v1.4.5

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L5
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für RefFrames : 4 frames
    Codec-ID : V_MPEG4/ISO/AVC
    Dauer : 32 min 7s
    Bitrate : 20,7 Mb/s
    Breite : 2 048 Pixel
    Höhe : 1 152 Pixel
    Bildseitenverhältnis : 16:9
    Modus der Bildwiederholungsrate : konstant
    Bildwiederholungsrate : 50,000 FPS
    ColorSpace : YUV
    ChromaSubsampling/String : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : progressiv
    Bits/(Pixel*Frame) : 0.176
    Stream-Größe : 4,65 GiB (97%)
    verwendete Encoder-Bibliothek : x264 core 148 r2744 b97ae06
    Kodierungseinstellungen : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=500 / keyint_min=50 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=23.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
    Default : Ja
    Forced : Nein

    Audio
    ID : 2
    Format : FLAC
    Format/Info : Free Lossless Audio Codec
    Codec-ID : A_FLAC
    Dauer : 32 min 7s
    Bitraten-Modus : variabel
    Bitrate : 542 kb/s
    Kanäle : 2 Kanäle
    Kanal-Positionen : Front: L R
    Samplingrate : 44,1 kHz
    Bildwiederholungsrate : 10,767 FPS (4096 SPF)
    BitDepth/String : 16 bits
    Stream-Größe : 124 MiB (3%)
    verwendete Encoder-Bibliothek : libFLAC 20080709 (UTC 2008-07-09)
    Default : Ja
    Forced : Nein




    Liebe Grüße
    KelkrexLP
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von KelkrexLP ()

  • Tritt das Problem nur bei TTT auf oder auch in anderen Spielen? Und tritt es auf, wenn du mal testweise auf 30 FPS zurückgehst?

    Ich hatte mal bei Just Cause 3 ein ähnliches Phänomen und war fast am Verzweifeln, bis ich gesehen habe, dass es im Spiel eine ganz besondere Art des Antialiasing gab, die ein Vegas-ähnliches Resampling reingemogelt hat – gibt es bei TTT vielleicht auch solche Grafikeinstellungen?
  • Es tritt nur bei TTT auf. Die nächste Folge die ich encodierte war wieder ganz normal, ohne Schlieren und hatte aber ebenfalls 50 FPS. Habe somit nichts verstellen müssen.
    Bisher trat das ganze nur bei TTT auf. Ich müsste mal schauen, ob es eine Option namens "Antialiasing" gibt. Aber danke schon mal für den Hinweis.:)

    Nachtrag: Der Antialiasing Modus ist in den Optionen zwar vorhanden aber komplett ausgeschalten.
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von KelkrexLP ()

  • Anzeige
    Es sollte zwar noch nicht hochgeladen werden, aber ich kann es ja mal auf "Nicht gelistet" setzen und dir hier den Link posten. Dauert nur bisschen. :)

    Merkwürdiger Weise hatte ich das Phänomen sogar schon mal mitten im Video, dass es in einem 30 minütigen Video ab Minute 20 plötzlich auftrat und vorher die ganze Zeit nicht. ?(
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • Der FICV Codec den es halt bei Mirillis Action z.B. gibt ist ein Verlust Codec. !!! - Kein Verlustfreier- !!!

    FICV - Fast Intra Compression Video

    Intra - Schlüsselbilder / Keyframe

    Der Codec basiert wie MJPEG auch auf Verlust Kompression wo es nur vollwertige I-Frames gibt. Die Bilder / Qualität sind vom Codec abhängig. z.B. sind MJPEG Videos auch Verlust Videos, wo am Ende in der Aufnahme selbst schon Artefakte gibt. Jedoch kann man den MJPEG zwecks Qualität ja einstellen. Aber selbst eine 100% Qualitätsangabe heißt nicht das das Video Verlustfrei ist. Es existiert immer noch die JPEG spezifischen Kompressionen.
    Gleiche Herangehensweise macht der FICV auch.

    Eine zweite Verarbeitung kann das schon recht schnell ruinieren.

    Soll heißen... der FICV kann wie MJPEG halt auch bei unterschiedlichen komplexen Materialien der Frames eines Videos unterschiedlich reagieren. z.B. in Form von unzureichender Bitrate. Ist die Bitrate gecapt bei einer bestimmten Menge wird jedes noch so komplexe Video in Artefakte und Schlieren sich präsentieren.

    Was die Sache noch schlimmer machen kann ist das nochmalige Enkodieren dieser Videos. Und spätestens Youtube wird bei sehr komplexen Material dir einen Strich durch die Rechnung machen.


    @De-M-oN hatte ja schon oft gesagt in letzter Zeit das Youtube die Bitrate auf sämtlichen Stufen gesenkt hat. Das erhöht natürlich die Wahrscheinlichkeit das komplexe Frames eines Videos dann in Artefakte oder Schlieren sich zeigen.

    Und zwecks FICV hatten wir im Forum auch schon einen Test gemacht mit komplexen Material. FICV hat da leider verloren, weil es zu viele Schlieren und Artefakte bei der Aufnahme schon aufwies gegenüber einem Lossless Codec wie UTVideo / Fraps.
    Wenn einer den Thread noch mal finden sollte im Archiv, kann er diesen gerne hier auch noch mal verlinken. ^^
  • Julien schrieb:

    Das Phänomen tritt also bei identischen Einstellungen nur sporadisch auf? ?( Hättest du davon mal ein Video zum Verdeutlichen?
    So, hier ist das Video, bei dem das ganze ziemlich gut sichtbar ist. :)
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von KelkrexLP ()

  • Sagaras schrieb:

    Wenn einer den Thread noch mal finden sollte im Archiv, kann er diesen gerne hier auch noch mal verlinken.
    Meinst du den Thread, bei dem im Endvideo die Unterschiede ohne Frame-Vergleiche so geringfügig waren, dass sich selbst De-M-oN vertan hat? Den hab ich immer noch in den Bookmarks: Mirillis totaler Quatsch?

    KelkrexLP schrieb:

    So, hier ist das Video, bei dem das ganze ziemlich gut sichtbar ist.
    Sieht sehr scheiße und etwas nach Interlaced-Streifen aus. Kannst du ...
    • ... die Aufnahme kontrollieren, ob du tatsächlich progressiv aufnimmst? Keine Ahnung, wo das in Craption steht.
    • ... schauen, wie Vegas das importiert?
    • ... die Projekt- und die Rendereinstellungen in Vegas kontrollieren, ob dort irgendwas bzgl. Interlaced steht?
    MfG
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von RealLiVe ()

  • Sagaras schrieb:

    @De-M-oN hatte ja schon oft gesagt in letzter Zeit das Youtube die Bitrate auf sämtlichen Stufen gesenkt hat.
    Nicht alle. Aber seit juli 2016 sind halt ID 308 und 315 leider enorm runtergesetzt worden...

    RealLiVe schrieb:

    Meinst du den Thread, bei dem im Endvideo die Unterschiede ohne Frame-Vergleiche so geringfügig waren, dass sich selbst De-M-oN vertan hat?
    Der war komplett eindeutig.. wie oft soll ichs eig noch sagen das ich am falschen ort geguckt habe.. (Dunkelheit. Der codec hat jedoch stattdessen bei komplexität gespart.)
    Sonderlich marginal war der unterschied dort dann absolut nicht mehr. Ich versteh nicht wieso du das einfach nicht raffst
    Aktuelle Projekte/Videos


  • RealLiVe schrieb:

    Sieht sehr scheiße und etwas nach Interlaced-Streifen aus. Kannst du ...
    • ... die Aufnahme kontrollieren, ob du tatsächlich progressiv aufnimmst? Keine Ahnung, wo das in Craption steht.
    • ... schauen, wie Vegas das importiert?
    • ... die Projekt- und die Rendereinstellungen in Vegas kontrollieren, ob dort irgendwas bzgl. Interlaced steht?
    MfG
    Ich habe jetzt mal in den Projekteinstellungen etwas von Deinterlace-Verfahren gefunden und da ist bei mir "Felder mischen" eingestellt.
    Zusätzlich fand ich einen Punkt namens "Feldreihenfolge" in den Projekteinstellungen, bei dem ich "Kein (Progressiv Scan)" auswählen kann und momentan "Oberes Feld zuerst" eingestellt ist.
    Nachdem ich allerdings mit Mirillis Action aufnehme, kann ich leider nicht wirklich feststellen, ob ich progressiv aufnehme. :-/
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von KelkrexLP ()

  • Ja gut, dass das schlecht ist, hab ich spätestens jetzt erkannt ;) Habe jetzt "Kein (Progressiv Scan)" eingestellt und bei "Deinterlace-Verfahren" hab ich nun "Felder interpolieren" eingestellt und nun ist in der Rendervorschau kein Interlacing mehr zu sehen. :) Ach ist das schön :D
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • KelkrexLP schrieb:

    Nachdem ich allerdings mit Mirillis Action aufnehme, kann ich leider nicht wirklich feststellen, ob ich progressiv aufnehme. :-/
    Würde mich wundern, wenn es nicht progressiv wäre, aber ich kenne die Einstellungen von Müllis Craption nicht.

    KelkrexLP schrieb:

    Ja gut, dass das schlecht ist, hab ich spätestens jetzt erkannt Habe jetzt "Kein (Progressiv Scan)" eingestellt und bei "Deinterlace-Verfahren" hab ich nun "Felder interpolieren" eingestellt und nun ist in der Rendervorschau kein Interlacing mehr zu sehen. Ach ist das schön
    Dann scheint es vorerst zu passen. Kleine Frage: Hast du das aktiv selber falsch eingestellt? Oder verwendest du versehentlich eine Interlaced-Vorlage? Oder hat dir Vegas in die Einstellungen geschissen, als es die .. "Videoeinstellungen Ihres Projekts an dieses Medium" angepasst hat? Letzteres hat bei mir paradoxerweise eigentlich recht zuverlässig funktioniert.

    Schließe mich aber mal den Empfehlungen an: Würde dir ebenfalls raten, dir auch mal die anderen Tools näher anzuschauen.

    De-M-oN schrieb:

    Der war komplett eindeutig.. wie oft soll ichs eig noch sagen das ich am falschen ort geguckt habe..
    So 2, 300 mal vielleicht :D Die Begründung bleibt die selbe wie beim letzten Mal.
    Spoiler anzeigen

    RealLiVe schrieb:

    De-M-oN schrieb:

    Oh man. ich hab auch nur im dunklen bereich geguckt. Bei dem komplexen bereich hätt ichs auch direkt gesehen. Warum hältst du mir das jetzt ständig vor? Der Bildvergleich ist doch nun wirklich mehr als deutlich! Und echt nicht mehr marginal.
    Verlustfrei bleibt die bessere Basis, das sagt allein schon die Logik und dass diese auch praktisch korrekt ist beweisen die Screenshots - das ist nicht zu leugnen. Wie man das trotzdem schafft, ist mir selbst ein Rätsel :P Allerdings, was diese Screenshots nicht zu zeigen vermögen: Wie drastisch nehmen wir das im Endprodukt (Youtube) selbst wahr? Das beantworteten mir allerdings die Beiträge im Thread, die gar von besserer Dunkelheit und besseren Farben/Kontrasten sprechen - deinen mit eingeschlossen. Man tut sich ohne einen Frame-Vergleich sehr schwer, wie auch Sagaras mal einräumte ...

    Sagaras schrieb:

    Selbst ein De-M-oN wie RealLiVe es schön zitiert hat konnte eine Lossy Aufnahme nicht von einer Lossless Aufnahme unterscheiden am Anfang ohne einen direkten Frame Vergleich zu haben. Hast du kein Vergleichsbild gegenüberstehen, siehst du es nicht ob das eine Matschiger ist als das andere. Das würde selbst dir so ergehen das du es nicht unterscheiden könntest ohne ein Framevergleich direkt.
    Wenn selbst du mit deiner Erfahrung und deinem Equipment zuerst falsch lagst, wie schaut's dann bei weniger erfahrenen Nutzern aus? Oder einem Nutzer, der nicht gezielt danach sucht? Würde das, ohne die Einzelbilder direkt zu vergleichen, als herbes Defizit aufgefasst werden? Kommt drauf an, wie stark das Material angegriffen wurde, oft genug würde die Antwort aber "Nein" sein. [...]
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte
  • RealLiVe schrieb:

    So 2, 300 mal vielleicht Die Begründung bleibt die selbe wie beim letzten mal.
    und die antwort die gleiche.
    Hätte ich direkt auf den komplexen teil geguckt, wäres auch aufgefallen. Dafür ist das viel zu eindeutig. Hab ich halt mal falsch geguckt. Wird die welt jetzt auch nicht sterben von. Guckt man dann doch auf den richtigen teil tuts halt dann doch bisschen weh. Aber mit den jetzigen caps von yt sieht ja jetzt eh jedes schwerer zu komprimierendes spiel scheiße auf yt aus..
    Aktuelle Projekte/Videos


  • RealLiVe schrieb:

    Dann scheint es vorerst zu passen. Kleine Frage: Hast du das aktiv selber falsch eingestellt? Oder verwendest du versehentlich eine Interlaced-Vorlage? Oder hat dir Vegas in die Einstellungen geschissen, als es die .. "Videoeinstellungen Ihres Projekts an dieses Medium" angepasst hat? Letzteres hat bei mir paradoxerweise eigentlich recht zuverlässig funktioniert.
    Ich sag mal so: Es war vorab schon so eingestellt und ich hab bis auf die FPS und der Qualitätseinstellungen nie irgendetwas verändert, weil ich bis jetzt auch nie Probleme hatte. :)
    Meine Livestreams auf Twitch: Kelkrex


    Streamplan wird immer montags aktualisiert. Normale Streamzeiten: Dienstag, Donnerstag und Samstag ab 18:00 Uhr!


  • Naja wenn du auf progressivem Video 'nen Deinterlacer bügelst, weil du dem Programm erzählst das Quellvideo sei interlaced, dann haste eig. immer die zeilenbildung auf Bewegung. Das kann also eig. nicht sein, das es da vorher keine Probleme gab. Dann hast du sie höchstens nicht bemerkt. Aber scheiße war das bei jedem Video xD
    Aber das sind alles so Zustände die nicht sein müssten, wenn diese Timeline Programme nicht so eine Vorlagenaufdringlichkeit hätten. Quellvideoeigenschaften selbst erkennen und anzeigen was erkannt wurde. Bei Bedarf anpassen. Da brauchts keine Vorlagen.. Vorlagen sollten optional sein und nicht einem aufgedrungen werden. Und letzteres ist ja leider das Problem an diesen ganzen Programmen. Und dann passieren solche Dinge halt. Zumal sich ja auch nicht erkundigt wird, was die einzelnen Settings bedeuten nach dem Motto wird schon passen.
    Aktuelle Projekte/Videos


  • De-M-oN schrieb:

    Aber das sind alles so Zustände die nicht sein müssten, wenn diese Timeline Programme nicht so eine Vorlagenaufdringlichkeit hätten. Quellvideoeigenschaften selbst erkennen und anzeigen was erkannt wurde.
    Normalerweise macht's Vegas auch so. Du ziehst das Video rein, es fragt dich beim ersten Clip, ob es die Projekteinstellungen anpassen soll und dann passt es die Einstellungen an. Klappt i.d.R. recht gut.
    Videoempfehlungen:
    ShimmyMC
    NuRap
    ShimmyMC
    Napoleon Bonaparte