OBS Studio - Webcam asynchron

  • OBS Studio - Webcam asynchron

    Anzeige
    Hey Leute!

    Wollte jetzt endlich mit OBS anfangen aufzunehmen, allerdings war das Spiel asynchron zu dem, was ich sagte und der Webcam Aufnahme. Also hab ich auf die Webcam den Delay Filter darauf gemacht, ebenso auf das Mikro. In der Theorie hat es funktioniert, mein gesagtes und das Spiel sind synchron, nur stimmt es nun nicht mehr mit der Webcam überein. Was mich sehr irritiert, da ich sowohl bei der Webcam als auch meinem Auna Mikro ein Delay von 1000 ms eingestellt habe. Und auch der Versuch Mikro und Webcam ein paar Hundert ms auseinander einzustellen, hat es nicht verbessert. Vielleicht hat jemand eine Idee, woran es liegen könnte.

    Lg PoisonRose

    Diesmal auch brav mit der Logdetei :)

    18:05:05.071:
    18:05:05.071: ================================
    18:05:05.071: Warning: OBS is already running!
    18:05:05.071: ================================
    18:05:05.071:
    18:06:06.737: User is now running a secondary instance of OBS!
    18:06:06.741: CPU Name: Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz
    18:06:06.741: CPU Speed: 4200MHz
    18:06:06.741: Physical Cores: 4, Logical Cores: 8
    18:06:06.741: Physical Memory: 16302MB Total, 13078MB Free
    18:06:06.741: Windows Version: 10.0 Build 16299 (revision: 309; 64-bit)
    18:06:06.741: Running as administrator: false
    18:06:06.741: Aero is Enabled (Aero is always on for windows 8 and above)
    18:06:06.742: Windows 10 Gaming Features:
    18:06:06.742: Game DVR: On
    18:06:06.743: Sec. Software Status:
    18:06:06.743: Windows Defender Antivirus: enabled (AV)
    18:06:06.743: Windows-Firewall: enabled (FW)
    18:06:06.743: Windows Defender Antivirus: enabled (ASW)
    18:06:06.744: Portable mode: false
    18:06:06.756: OBS 21.0.1 (64bit, windows)
    18:06:06.756: ---------------------------------
    18:06:06.757: ---------------------------------
    18:06:06.757: audio settings reset:
    18:06:06.757: samples per sec: 44100
    18:06:06.757: speakers: 2
    18:06:06.757: ---------------------------------
    18:06:06.757: Initializing D3D11...
    18:06:06.757: Available Video Adapters:
    18:06:06.758: Adapter 1: NVIDIA GeForce GTX 750 Ti
    18:06:06.758: Dedicated VRAM: 2115698688
    18:06:06.758: Shared VRAM: 4252051456
    18:06:06.758: output 1: pos={0, 0}, size={1920, 1080}, attached=true
    18:06:06.758: output 2: pos={-1366, 0}, size={1366, 768}, attached=true
    18:06:06.759: Loading up D3D11 on adapter NVIDIA GeForce GTX 750 Ti (0)
    18:06:06.774: D3D11 loaded successfully, feature level used: 45056
    18:06:07.299: ---------------------------------
    18:06:07.299: video settings reset:
    18:06:07.299: base resolution: 1920x1080
    18:06:07.299: output resolution: 1920x1080
    18:06:07.299: downscale filter: Bicubic
    18:06:07.299: fps: 60/1
    18:06:07.299: format: NV12
    18:06:07.301: Audio monitoring device:
    18:06:07.301: name: Standard
    18:06:07.301: id: default
    18:06:07.301: ---------------------------------
    18:06:07.302: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
    18:06:07.303: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
    18:06:07.358: [AMF] <obs_module_load> AMF not supported (no AMD graphics)
    18:06:07.358: Failed to initialize module 'enc-amf.dll'
    18:06:07.365: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
    18:06:07.365: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libEGL.dll' not found, loading of module failed
    18:06:07.365: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
    18:06:07.365: Failed to load 'en-US' text for module: 'obs-browser.dll'
    18:06:07.365: [browser_source: 'Version: 1.29.0']
    18:06:07.367: NVENC supported
    18:06:07.395: Couldn't find VLC installation, VLC video source disabled
    18:06:07.396: No blackmagic support
    18:06:07.432: ---------------------------------
    18:06:07.432: Loaded Modules:
    18:06:07.432: win-wasapi.dll
    18:06:07.432: win-mf.dll
    18:06:07.432: win-dshow.dll
    18:06:07.432: win-decklink.dll
    18:06:07.432: win-capture.dll
    18:06:07.432: vlc-video.dll
    18:06:07.432: text-freetype2.dll
    18:06:07.432: rtmp-services.dll
    18:06:07.432: obs-x264.dll
    18:06:07.432: obs-vst.dll
    18:06:07.432: obs-transitions.dll
    18:06:07.432: obs-text.dll
    18:06:07.432: obs-qsv11.dll
    18:06:07.432: obs-outputs.dll
    18:06:07.432: obs-filters.dll
    18:06:07.432: obs-ffmpeg.dll
    18:06:07.432: obs-browser.dll
    18:06:07.432: image-source.dll
    18:06:07.432: frontend-tools.dll
    18:06:07.432: enc-amf.dll
    18:06:07.432: coreaudio-encoder.dll
    18:06:07.432: ---------------------------------
    18:06:07.432: ==== Startup complete ===============================================
    18:06:07.434: All scene data cleared
    18:06:07.434: ------------------------------------------------
    18:06:07.451: WASAPI: Device 'Mikrofon (3- Auna Mic CM900)' initialized
    18:06:07.469: WASAPI: Device 'Lautsprecher (Turtle Beach PX22)' initialized
    18:06:07.476: Switched to scene 'Szene'
    18:06:07.477: ------------------------------------------------
    18:06:07.477: Loaded scenes:
    18:06:07.477: - scene 'Szene':
    18:06:07.477: - source: 'Elgato' (dshow_input)
    18:06:07.477: - source: 'Auna' (wasapi_input_capture)
    18:06:07.477: - source: 'Turtle Beach' (wasapi_output_capture)
    18:06:07.477: - source: 'Webcam' (dshow_input)
    18:06:07.477: - filter: 'Videoverzögerung (Asynchron)' (async_delay_filter)
    18:06:07.477: ------------------------------------------------
    18:06:07.680: ---------------------------------
    18:06:07.680: [DShow Device: 'Webcam'] settings updated:
    18:06:07.680: video device: Microsoft® LifeCam HD-3000
    18:06:07.680: video path: \\?\usb#vid_045e&pid_0779&mi_00#7&1d76894f&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
    18:06:07.680: resolution: 640x480
    18:06:07.680: fps: 30.00 (interval: 333333)
    18:06:07.680: format: YUY2
    18:06:08.134: A sprite cannot be drawn without a width/height
    18:06:08.151: A sprite cannot be drawn without a width/height
    18:06:08.167: A sprite cannot be drawn without a width/height
    18:06:08.185: A sprite cannot be drawn without a width/height
    18:06:08.201: A sprite cannot be drawn without a width/height
    18:06:08.218: A sprite cannot be drawn without a width/height
    18:06:08.235: A sprite cannot be drawn without a width/height
    18:06:08.251: A sprite cannot be drawn without a width/height
    18:06:08.268: A sprite cannot be drawn without a width/height
    18:06:08.285: A sprite cannot be drawn without a width/height
    18:06:08.301: A sprite cannot be drawn without a width/height
    18:06:08.318: A sprite cannot be drawn without a width/height
    18:06:08.334: A sprite cannot be drawn without a width/height
    18:06:08.351: A sprite cannot be drawn without a width/height
    18:06:08.368: A sprite cannot be drawn without a width/height
    18:06:08.384: A sprite cannot be drawn without a width/height
    18:06:08.401: A sprite cannot be drawn without a width/height
    18:06:08.418: A sprite cannot be drawn without a width/height
    18:06:08.434: A sprite cannot be drawn without a width/height
    18:06:08.451: A sprite cannot be drawn without a width/height
    18:06:08.468: A sprite cannot be drawn without a width/height
    18:06:08.484: A sprite cannot be drawn without a width/height
    18:06:08.501: A sprite cannot be drawn without a width/height
    18:06:08.518: A sprite cannot be drawn without a width/height
    18:06:08.534: A sprite cannot be drawn without a width/height
    18:06:08.551: A sprite cannot be drawn without a width/height
    18:06:08.567: A sprite cannot be drawn without a width/height
    18:06:08.584: A sprite cannot be drawn without a width/height
    18:06:08.601: A sprite cannot be drawn without a width/height
    18:06:08.618: A sprite cannot be drawn without a width/height
    18:06:08.634: A sprite cannot be drawn without a width/height
    18:06:10.079: Last log entry repeated for 24 more lines
    18:06:10.079: ---------------------------------
    18:06:10.079: [DShow Device: 'Elgato'] settings updated:
    18:06:10.079: video device: Elgato Game Capture HD
    18:06:10.079: video path: __elgato
    18:06:10.079: resolution: 1920x1080
    18:06:10.079: fps: 30.00 (interval: 333333)
    18:06:10.079: format: UYVY
    18:06:10.079: using video device audio: yes
    18:06:10.079: sample rate: 48000
    18:06:10.079: channels: 2
    18:06:10.079: audio type: Capture
    18:06:16.980: adding 278 milliseconds of audio buffering, total audio buffering is now 278 milliseconds
    18:06:17.252: adding 23 milliseconds of audio buffering, total audio buffering is now 301 milliseconds
    18:06:17.523: adding 69 milliseconds of audio buffering, total audio buffering is now 371 milliseconds
    18:06:24.383: ---------------------------------
    18:06:24.383: [x264 encoder: 'recording_h264'] preset: veryfast
    18:06:24.383: [x264 encoder: 'recording_h264'] profile: high
    18:06:24.383: [x264 encoder: 'recording_h264'] settings:
    18:06:24.383: rate_control: CRF
    18:06:24.383: bitrate: 0
    18:06:24.383: buffer size: 0
    18:06:24.383: crf: 18
    18:06:24.383: fps_num: 60
    18:06:24.383: fps_den: 1
    18:06:24.383: width: 1920
    18:06:24.383: height: 1080
    18:06:24.383: keyint: 250
    18:06:24.383:
    18:06:24.389: [Media Foundation AAC: 'Track1']: encoder created
    18:06:24.389: bitrate: 160
    18:06:24.389: channels: 2
    18:06:24.389: sample rate: 44100
    18:06:24.389: bits-per-sample: 16
    18:06:24.389:
    18:06:24.415: ==== Recording Start ===============================================
    18:06:24.415: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/User/Videos/2018-03-18 18-06-24.mp4'...
    18:06:44.694: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/User/Videos/2018-03-18 18-06-24.mp4' stopped
    18:06:44.694: Output 'adv_file_output': stopping
    18:06:44.694: Output 'adv_file_output': Total frames output: 1191
    18:06:44.694: Output 'adv_file_output': Total drawn frames: 1217
    18:06:44.694: ==== Recording Stop ================================================
    18:07:27.879: ---------------------------------
    18:07:27.879: [x264 encoder: 'recording_h264'] preset: veryfast
    18:07:27.879: [x264 encoder: 'recording_h264'] profile: high
    18:07:27.879: [x264 encoder: 'recording_h264'] settings:
    18:07:27.879: rate_control: CRF
    18:07:27.879: bitrate: 0
    18:07:27.879: buffer size: 0
    18:07:27.879: crf: 18
    18:07:27.879: fps_num: 60
    18:07:27.879: fps_den: 1
    18:07:27.879: width: 1920
    18:07:27.879: height: 1080
    18:07:27.879: keyint: 250
    18:07:27.879:
    18:07:27.883: [Media Foundation AAC: 'Track1']: encoder created
    18:07:27.883: bitrate: 160
    18:07:27.883: channels: 2
    18:07:27.883: sample rate: 44100
    18:07:27.883: bits-per-sample: 16
    18:07:27.883:
    18:07:27.906: ==== Recording Start ===============================================
    18:07:27.906: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/User/Videos/2018-03-18 18-07-27.mp4'...
    18:07:45.561: adding 23 milliseconds of audio buffering, total audio buffering is now 394 milliseconds
    18:08:54.180: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/User/Videos/2018-03-18 18-07-27.mp4' stopped
    18:08:54.180: Output 'adv_file_output': stopping
    18:08:54.180: Output 'adv_file_output': Total frames output: 5149
    18:08:54.180: Output 'adv_file_output': Total drawn frames: 5176
    18:08:54.180: ==== Recording Stop ================================================
    18:12:40.859: adding 23 milliseconds of audio buffering, total audio buffering is now 417 milliseconds
    18:20:14.453: ==== Shutting down ==================================================
    18:20:14.460: Switched to scene '(null)'
    18:20:17.150: WASAPI: Device 'Mikrofon (3- Auna Mic CM900)' Terminated
    18:20:17.155: WASAPI: Device 'Lautsprecher (Turtle Beach PX22)' Terminated
    18:20:17.420: All scene data cleared
    18:20:17.420: ------------------------------------------------
    18:20:17.459: Freeing OBS context data
    18:20:17.687: [Scripting] Total detached callbacks: 0
    18:20:17.692: == Profiler Results =============================
    18:20:17.692: run_program_init: 62465.1 ms
    18:20:17.692: ┣OBSApp::AppInit: 10.165 ms
    18:20:17.692: ┃ ┗OBSApp::InitLocale: 1.478 ms
    18:20:17.692: ┗OBSApp::OBSInit: 775.303 ms
    18:20:17.692: ┣obs_startup: 2.576 ms
    18:20:17.692: ┗OBSBasic::OBSInit: 756.689 ms
    18:20:17.692: ┣OBSBasic::InitBasicConfig: 0.29 ms
    18:20:17.692: ┣OBSBasic::ResetAudio: 0.106 ms
    18:20:17.692: ┣OBSBasic::ResetVideo: 543.675 ms
    18:20:17.692: ┣OBSBasic::InitOBSCallbacks: 0.003 ms
    18:20:17.692: ┣OBSBasic::InitHotkeys: 0.039 ms
    18:20:17.692: ┣obs_load_all_modules: 130.795 ms
    18:20:17.692: ┃ ┣obs_init_module(coreaudio-encoder.dll): 0.232 ms
    18:20:17.692: ┃ ┣obs_init_module(enc-amf.dll): 54.784 ms
    18:20:17.692: ┃ ┣obs_init_module(frontend-tools.dll): 2.9 ms
    18:20:17.692: ┃ ┣obs_init_module(image-source.dll): 0.003 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-browser.dll): 0.038 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-ffmpeg.dll): 0.445 ms
    18:20:17.692: ┃ ┃ ┗nvenc_check: 0.421 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-filters.dll): 0.009 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-outputs.dll): 0.005 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-qsv11.dll): 22.202 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-text.dll): 0.315 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-transitions.dll): 0.003 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-vst.dll): 0.001 ms
    18:20:17.692: ┃ ┣obs_init_module(obs-x264.dll): 0 ms
    18:20:17.692: ┃ ┣obs_init_module(rtmp-services.dll): 0.544 ms
    18:20:17.692: ┃ ┣obs_init_module(text-freetype2.dll): 0.028 ms
    18:20:17.692: ┃ ┣obs_init_module(vlc-video.dll): 0.022 ms
    18:20:17.692: ┃ ┣obs_init_module(win-capture.dll): 0.036 ms
    18:20:17.692: ┃ ┣obs_init_module(win-decklink.dll): 0.466 ms
    18:20:17.692: ┃ ┣obs_init_module(win-dshow.dll): 0.67 ms
    18:20:17.692: ┃ ┣obs_init_module(win-mf.dll): 32.45 ms
    18:20:17.692: ┃ ┣obs_init_module(win-wasapi.dll): 0.003 ms
    18:20:17.692: ┃ ┗reset_win32_symbol_paths: 0.059 ms
    18:20:17.692: ┣OBSBasic::ResetOutputs: 0.307 ms
    18:20:17.692: ┣OBSBasic::CreateHotkeys: 0.019 ms
    18:20:17.692: ┣OBSBasic::InitService: 0.668 ms
    18:20:17.692: ┣OBSBasic::InitPrimitives: 0.14 ms
    18:20:17.692: ┗OBSBasic::Load: 43.919 ms
    18:20:17.692: obs_hotkey_thread(25 ms): min=0.002 ms, median=0.005 ms, max=7.064 ms, 99th percentile=0.16 ms, 100% below 25 ms
    18:20:17.692: audio_thread(Audio): min=0 ms, median=0.06 ms, max=7.018 ms, 99th percentile=0.512 ms
    18:20:17.692: ┗receive_audio: min=0 ms, median=0.231 ms, max=5.763 ms, 99th percentile=0.558 ms, 0.121833 calls per parent call
    18:20:17.692: ┣buffer_audio: min=0 ms, median=0 ms, max=0.021 ms, 99th percentile=0.002 ms
    18:20:17.692: ┗do_encode: min=0.126 ms, median=0.229 ms, max=5.76 ms, 99th percentile=0.551 ms
    18:20:17.692: ┗encode(Track1): min=0.121 ms, median=0.207 ms, max=0.993 ms, 99th percentile=0.408 ms
    18:20:17.692: obs_graphics_thread(16.6667 ms): min=0.197 ms, median=0.783 ms, max=20.57 ms, 99th percentile=2.971 ms, 99.998% below 16.667 ms
    18:20:17.692: ┣tick_sources: min=0.001 ms, median=0.007 ms, max=19.145 ms, 99th percentile=0.018 ms
    18:20:17.692: ┣output_frame: min=0.194 ms, median=0.633 ms, max=13.926 ms, 99th percentile=2.607 ms
    18:20:17.692: ┃ ┣gs_context(video->graphics): min=0.113 ms, median=0.279 ms, max=13.613 ms, 99th percentile=1.391 ms
    18:20:17.692: ┃ ┃ ┣render_video: min=0.015 ms, median=0.146 ms, max=9.825 ms, 99th percentile=1.189 ms
    18:20:17.692: ┃ ┃ ┃ ┣render_main_texture: min=0.002 ms, median=0.126 ms, max=9.763 ms, 99th percentile=1.126 ms
    18:20:17.692: ┃ ┃ ┃ ┣render_output_texture: min=0.002 ms, median=0.004 ms, max=1.256 ms, 99th percentile=0.011 ms
    18:20:17.692: ┃ ┃ ┃ ┣render_convert_texture: min=0.001 ms, median=0.007 ms, max=2.751 ms, 99th percentile=0.015 ms
    18:20:17.692: ┃ ┃ ┃ ┗stage_output_texture: min=0 ms, median=0.003 ms, max=3.494 ms, 99th percentile=0.042 ms
    18:20:17.692: ┃ ┃ ┣download_frame: min=0 ms, median=0.002 ms, max=13.175 ms, 99th percentile=0.161 ms
    18:20:17.692: ┃ ┃ ┗gs_flush: min=0.016 ms, median=0.063 ms, max=9.154 ms, 99th percentile=0.187 ms
    18:20:17.692: ┃ ┗output_video_data: min=0.252 ms, median=0.335 ms, max=9.384 ms, 99th percentile=1.174 ms
    18:20:17.692: ┗render_displays: min=0 ms, median=0.108 ms, max=7.792 ms, 99th percentile=0.379 ms
    18:20:17.692: video_thread(video): min=0 ms, median=0.001 ms, max=19.461 ms, 99th percentile=2.593 ms
    18:20:17.692: ┗receive_video: min=0 ms, median=1.825 ms, max=19.458 ms, 99th percentile=4.002 ms, 0.125341 calls per parent call
    18:20:17.692: ┗do_encode: min=1.382 ms, median=1.824 ms, max=19.457 ms, 99th percentile=4 ms
    18:20:17.692: ┗encode(recording_h264): min=1.362 ms, median=1.787 ms, max=19.446 ms, 99th percentile=3.812 ms
    18:20:17.692: =================================================
    18:20:17.692: == Profiler Time Between Calls ==================
    18:20:17.692: obs_hotkey_thread(25 ms): min=24.126 ms, median=25.159 ms, max=39.743 ms, 81.6956% within ±2% of 25 ms (0.0831749% lower, 18.2212% higher)
    18:20:17.692: obs_graphics_thread(16.6667 ms): min=3.931 ms, median=16.667 ms, max=29.938 ms, 99.1942% within ±2% of 16.667 ms (0.405819% lower, 0.399937% higher)
    18:20:17.692: =================================================
    18:20:17.764: Number of memory leaks: 1
    Wie auf Rosen gebettet...oder so. (Ja das ist der Link zu meinem Kanal^^)
  • Asynchronität bin ich auch von meiner C920 gewohnt. Da ich die aber nicht oft einsetze, bin ich jedes Mal am Rumprobieren, bis es endlich wieder funktioniert.

    Deine Webcam ist ja etwas billiger; es kann schon sehr helfen, wenn du die Lichtverhältnisse optimierst. Dunkelheit stört gerne das Bild.

    Mit VirtualDub könntest du die Webcam auch aufnehmen zumindest als Test, um die Webcam (oder ggf. zugehörige Software) als Fehlerquelle auszuschließen oder zu sehen, ob tatsächlich OBS das Problem darstellt.
  • Anzeige

    PoisonRose schrieb:

    8:06:07.680: video device: Microsoft® LifeCam HD-3000
    Hast du die Software dafür installiert?
    microsoft.com/accessories/de-de/d/lifecam-hd-3000

    Die Auflösung dürfte mit 240p ausreichen.


    Zur Not Webcam mit VirtualDub separat aufnehmen und hinterher im Videobearbeitungsprogramm zusammenfügen.
    Mittelfristig würde ich eine bessere Kamera empfehlen, siehe auch: Cam vorschläge

    Wenn du lustig bist, kannst du auch mal OBS Classic ausprobieren.




    ....
    Oder du stellst mal alles auf 30 FPS. *hust*