OBS mit Teamspeak

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • OBS mit Teamspeak

    Anzeige
    Ahoi,

    ich bin gerade echt am verzweifeln und hoffe ihr habt eine Idee.

    Die Problemstellung:
    Ich möchte gerne in OBS den Spielsound und die Teamspeak-Ausgabe auf einem Soundkanal ausgegeben haben.
    Dies funktioniert aber nur, wenn ich für Desktop Audio in den "erweiterten Audioeinstellungen" alle 6 Spuren aktiviere, was wiederum dazu führt, dass ich auch auf meiner Mikro Aufnahme Spur den Desktop Audio habe (= doof).
    Sobald ich auch nur eine Spur für Desktop Audio deaktiviere, habe ich die Teamspeak-Ausgabe auf keiner Spur mehr hörbar.


    Über Doktor Google finde ich leider nur Fragestellungen, wie ich Teamspeak aus der Ausnahme herausbekomme (meist recht umständlich - über additive Programme). Das hätte ich quasi gelöst, aber ich brauche es andersrum (damit ich Teamspeak in einem Duo Game mit aufnehmen kann) ... :(


    Das muss in OBS lösbar sein, aber irgendwie krieg ichs nicht hin - eine Teamspeak Aufnahme geht einwandfrei und mit weiteren Tools gehts sicher auch, find ich aber alles nicht so optimal (zwecks Ressourcen Auslaungs auf dem PC).


    Ich hoffe ihr könnt mir helfen.


    Salute
    Larcath
    Schaut doch mal in meinem Lets Play - YouTube Channel vorbei!

    Aktuelle Projekte:
    - Playersunknown's Battlegrounds
    - VAMPYR
  • Vielleicht könntest du 1, 2 Bilder dazu liefern, damit die Problemstellung plastischer wird.

    Du nutzt das aktuelle OBS-Studio?
    Du möchtest mit OBS aufnehmen oder streamen und dabei 3 Audioquellen in 2 Spuren haben?
    - In der 1. Spur soll das Mikrofon stecken.
    - In der 2. Spur soll IGS + TS sein.

    Ich sehe darin kein Problem, weil TS normalerweise automatisch in derselben Quelle wie IGS ist.
    Bei den ganzen Audio-Haken bin ich allerdings auch schon durcheinander gekommen.
  • Ahoi,

    @Sem: exakt das möchte ich machen, klappt aber nicht (wenn ich es so einstelle, fehlt TS -> obwohl mir der OBS mixer anzeigt, dass Ton kommt).

    Einstellung:
    Recording = nur Spur 1 & 2
    Desktop Audio= Spur 1
    Micro = Spur 2

    Aktuelles OBS - keine AddOns, hab grad kein Web-Space verfügbar, daher keine Bilder.
    Evtl. könnte das von euch mal jemand testen, vielleicht habe ich nur irgendwas verstellt.


    @MrValrek: Danke für den Hinweis, aber genau das möchte ich nicht (wenn es nicht sein muss) - da alle Virtuellen Sound Emulatoren additv Ressourcen brauchen (CPU, RAM).


    Salute
    Larcath
    Schaut doch mal in meinem Lets Play - YouTube Channel vorbei!

    Aktuelle Projekte:
    - Playersunknown's Battlegrounds
    - VAMPYR
  • Anzeige
    Das Problem sollte eigentlich easy zu lösen sein. Nur mit dieser Fernwartung durch das Forum kann das dauern.

    Mein naheliegenster Verdacht wäre, dass die Audioeinstellungen im Teamspeak nicht auf Standart gestellt sind.

    So wie du und Sem das beschreiben, solltest du eigentlich gar nichts dafür einstellen müssen, weil dass absolut standart ist. So ist es auch bei mir.
    Wichtig ist, dass du OBS jedes mal wenn du im Windows das Ausgabegerät änderst, neustartest. Außer du hast OBS eh mit allen möglichen Audiogeräten ausgestattet.

    LG
    Mein Let's Play -> Youtubekanal -< ich freue mich über Besuch :saint:
  • Versteh das irgendwie nicht. Einerseits willst du alles auf einem Kanal haben aber dann stört es dich, wenn du den Spielsound auf der Mikrospur hast?! Genau das wolltest du doch?

    Ansonsten stellst du unter Einstellungen -> Ausgabe -> Aufnehmen erstmal grundsätzlich ein was du an Audiospuren/Geräten haben willst. Danach zurück zum Anfangsbildschirm, Zahnrädchen neben einem Audiogerät anklicken, "Erweiterte Audioeigenschaften" und dann pro Spur das anklicken was du haben willst. Also wenn du auf einer Spur Mikro und Spielsound haben willst bei der ersten Tonspur die Haken setzen wie du vorher in den Einstellungen die einzelnen Audiogeräte zugewiesen hast.
    Also du müsstest mit zwei Tonspuren hinkommen, eine exklusiv für dein Mikro, und eine zweite wo du dann zwei Haken setzen musst (2 und 3 von mir aus wenn Mikro 1 ist) für TS und das Spiel. Wobei ich lieber immer alles einzeln habe damit ich zur Not beim Bearbeiten nachpegeln kann - aber das muss jeder selbst wissen.

    So wirklich verstehen tue ich dein Problem aber nicht, finde deine Umschreibung irgendwie sehr irreführend.

    PS: Zum Bilder hochladen brauchst du keinen Webspace, nimm einen der 3,8 Milliarden Bilderhoster im Netz.
    Viele Grüße,

    Christian
    __________________________________
    YouTube
  • Scheinbar drücke ich mich tatsächlich zu umständlich aus, mal auf den Kern ...

    Wenn ich folgendes einstelle funktioniert es.

    Recording MP4 -> Tonspur 1-6 aktiv
    Desktop Audio = Spur 1-6
    Micro = Spur 2

    Bei dieser Einstellung habe ich TS (Ausgabe -> was mein Kumpel spricht) und Ingame Sound auf Spur 1, aber leider auch auf Spur 2 (inkl. Micro), dass will ich aber nicht, da ich Spur 2 noch bearbeiten will (z .B. Rauschfilter).

    Sobald ich die Einstellung auf folgendes setze (sonst nichts verändert) ...

    Recording MP4 -> Tonspur 1-6 aktiv
    Desktop Audio = Spur 1
    Micro = Spur 2

    Habe ich auf Spur 1 nur noch Ingame Sound (ohne TS) und auf Spur 2 nur Micro (wie gewollt).
    Problem: Ich habe TS (Ausgabe) in keiner Spur!


    Salute
    Larcath
    Schaut doch mal in meinem Lets Play - YouTube Channel vorbei!

    Aktuelle Projekte:
    - Playersunknown's Battlegrounds
    - VAMPYR
  • Wofür brauchst du sechs Spuren? Weise doch deine Geräte erstmal wie beschrieben den einzelnen Spuren zu. Und dann ist Mikro hinterher auf Spur 1, und auf Spur 2 packst du TS und das Spiel. Das ist ne Sache von 10 Sekunden, du hast anscheinend deine Geräte überhaupt nicht richtig zugewiesen und klickst da wahllos irgendwelche Quellen für die Spur zusammen.

    Hier fängst du an und benennst erstmal die Spuren, also 1 Mikrofon, 2 Ingame + TS:
    picload.org/view/dolggalr/1.png.html

    Dann machst du hier weiter und aktivierst nur die Spuren die du brauchst, also 1 und 2 in deinem Fall:
    picload.org/view/dolggala/2.png.html

    Und zum Schluss hier einfach die Geräte zuweisen, 1 das Mikro also Haken bei Spur 1, und 2 Spiel und TS, also Haken bei 2 und 3:
    picload.org/view/dolggall/3.png.html


    Fertig.
    Viele Grüße,

    Christian
    __________________________________
    YouTube
  • @game8:

    Erstmal danke, dass du immer noch versuchst zu helfen, aber exakt so war meine Einstellung, was zum Problem führt.

    Zur Erklärung für dich (was ich oben schon geschrieben hatte).

    Punkt 1: hat keine Relevanz = nur eine Benennung
    Punkt 2: Es ist egal ob 2 Spuren oder 6 Spuren (ich hatte das auf 6 geändert, da ich nur über alle 6 Spuren aktiv TS Ton erhalte)
    Punkt 3: Exakt das ist meine Einstellung -> WO ES NICHT FUNKTIONIERT!

    Langsam glaub ich, ich rede Chinesisch - aber nochmal, wenn ich ...

    A - Punkt 2 & 3 wie von dir genannt einstelle -> keine TS Ausgabe
    B - Punkt 2 = alle Spuren aktiv & Punkt 3: Desktop Audio = alle Spuren aktiv -> TS Ausgabe vorhanden!

    Das ganze im Standard (keine AddOns im OBS und kein Virtuelles Audio Programm).
    Ich ändere von A auf B nichts (weder im OBS noch sonst wo) und habe einmal kein TS und einmal volle Funktion.


    Salute
    Larcath
    Schaut doch mal in meinem Lets Play - YouTube Channel vorbei!

    Aktuelle Projekte:
    - Playersunknown's Battlegrounds
    - VAMPYR