MeGUI [2015] -- x264 - bester Encoder, beste Videoqualität auf Youtube ;-)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Ich kann nur sagen ich bin vollends zufrieden :D
      Auch wenns am Anfang recht verwirrend ist, nachdem De-M-oN alles für mich eingerichtet hat, funktioniert das alles perfekt!
      von 480p hoch auf original *O* Hach das war wie im Traum nur ohne Aufwachen danach ~<3
      Ich kanns nur wärmstens empfehlen :]
      Los! benutzt es! Ihr wollt es doch auch! xD

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ElikChan ()

    • Finde es auch Top. Nur eines stört mich ,dass bei einem 3 Part Video etliche Sound und Video Teile entstehen. Also für ein 15 min. Video habe ich dann 6 verschiedene Daten im Ordner liegen und muss die dann noch muxen. Oder es geht einfacher und ich mache es falsch :D
    • Anzeige
      MeGUI encodiert Audio und Video getrennt und diese müssen eben dann gemuxt werden. Ja.

      Weitere Dateien =

      .avs = Das Avisynth Script
      .ffindex = Die Index Datei, falls über FFVideoSource (dem File Indexer und dessen Job vorm Avisynth Script Creator) decodiert wurde.

      Muxen müsstest du aber so oder so nochmal mit MKVMerge, damit du eben eine MKV Datei erhältst die OHNE Kopfdatenkompression ist. Sonst gibts auf Youtube gern mal große Probleme mit deren Videoencode (entweder graues Video, oder Video gar nicht erst encodierbar)
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
    • Ich, dachte ich melde mich auch einmal zu Wort. Nachdem ich mir heute einmal die Zeit nahm, das Tutorial durcharbeitete, beschloss ich einen Erfahrungsbericht abzugeben.
      Zuerst danke ich für das übersichtliche Tutorial, zumindest das in Textform, das Video sah ich mir nicht an. Nach der Anleitung war es kinderleicht durchzuführen. Allerdings muss ich anmerken, dass ich mit unter stundenlang an einem Linux „rumfrickle“ und daher nicht unbedingt als Maßstab genommen werden kann.

      Ich nehme es mir raus, über das Material zu schreiben, das ich codierte, damit jemand der das hier liest, keine falsche Vorstellung bekommt. Es handelt sich dabei um Aufnahmen aus dem Spiel: Planescape:Torment, d.h. es gibt teilweise lange Standbilder, in denen sich nur Text ändert, allerdings auch zwischenzeitlich schnell komplett ändernde Umgebungen.
      Das Ergebnis sprich für sich.

      Mit De-M-oNs Preset schaffte es der Encoder das Video(1280x720) von 30:08 min, auf ca. 167 MiB zu verkleinern. Dazu kamen dann noch eine 41MiB Vorbis-Datei (192kbit/s@44,1kHz) die ich allerdings aus Sony Vegas Movie Studio 9.0 (Mikrophonspur und „Ingamesound“ zusammgeschnitten und bearbeitete) exportierte. In diesem ich auch die Videodatei in Lagarith vorbereitete.

      Um einen direkten Vergleich zu haben, renderte ich das Video auch ein 2. mal, natürlich aus dem Rohmaterial, direkt in Sony Vegas Movie Studio 9.0. Mit dem „Sony AVC“-Codec (CABAC@3000kbit/s+ AAC@192kbit/s)

      Das Ganze lief mit auf einem Windows XP Pro System(32bit) mit SP3
      CPU:Q9550 @ 2,83GHz
      RAM: 3,25GiB genutzter Arbeitsspeicher von dem effektiv 2GiB einem Programm zugeordnet werden können. (32bit WinXP halt)

      Das Ergebnis war:

      Mit MeGUI:

      Sony Vegas Movie Studio 9.0 => Rohmaterial(Video) zu Lagarith (Dauer:1h45min; Größe: 22,5GiB)
      Sony Vegas Movie Studio 9.0 => Rohmaterial(Audio) zu Vorbis (Dauer: 4min Größe:41MiB)
      MeGUI => Lagarith zu x264 (Dauer: 26min; Größe: 167 MiB)
      MKVMerge brauchte nur wenige Sekunden, um die Audio- sowie die Videospur in einen Container zu quetschen.
      Insgesamt renderte ich knapp 2h15min, die Größe der Datei entspricht 209MiB und das bei unglaublicher Qualität. Die Frage ist nur, was Youtube(720p) daraus machen wird und ob sich der Aufwand dafür lohnt. Man kann sich außerdem die Frage stellen, ob man lieber mehr Zeit in den Rendervorgang oder die Zeit des Uploads stecken möchte.

      Ein Nachtrag zu Vegas Movie Studio 9.0 und Lagarith:
      Ich denke, dass Vegas Movie Studio 9.0 und Lagarith, einen kleinen Konflikt, mit der Mehrkernunterstützung hatten/haben. Die Prozessorauslastung lag nämlich bei knapp 25% wären des Rendervorgangs, daher denke ich, dass der Wert nicht repräsentativ ist, sondern das in einem viertel der Zeit zu schaffen sei. Vielleicht hat jemand einen konstruktiven Tipp, der über das setzen der Mehrkernunterstützung im Codec hinaus geht?(Es wird nicht an dem Datendurchsatz der Festplatte liegen, da ich von einer Internen HDD auf eine andere gespeichert habe, Der Datendurchsatz liegt bei über 60MiB/s beim Kopieren von großen Datenpaketen.)

      Mit Sony Vegas Movie Studio 9.0:
      Sony Vegas Movie Studio 9.0 => Rohmaterial(Video und Audio) zu „Sony AVC“ (Rendereinstellung: Optimal; Auflösung:1280x720; CABAC@3000kbit/s+ AAC@192kbit/s;44,1kHz)
      Es dauerte insgesamt 53 Minuten und dabei kam ein Klotz von 688MiB raus. Das Video hat große Probleme mit dem grauen„Kriegsnebel“ besonders in Bewegung, es „verblockt“ dort sehr stark.

      Für den, der nicht überzeugt ist, habe ich 2 Beispielbilder gemacht.

      Sony AVC
      imageshack.us/photo/my-images/805/avc.png/
      bilder-hochladen.net/files/big/i0nf-1.png
      x264
      imageshack.us/photo/my-images/535/x264.png/
      bilder-hochladen.net/files/big/i0nf-2.png

      Sehr interessant ist ein 3. Renderdurchgang. Ergo der 2. den ich mit MeGUI machte. Wieder das gleiche Grundmaterial bzw. den Lagarithdatenblock. Diesmal allerdings mit der Resize-Option. Die Auflösung auf die das Video geändert wird ist 2560x1440 mit dem Bildfilter „Lanczos4“, also einer Vervierfachung der Bildpunkt. Die Dauer der Brechung betrug 1h06min. Der Videoblock ist 387MiB Groß, ein meiner Meinung nach sehr gutes Ergebnis. Leider kann ich keinen Vergleich mit Sony Vegas Movie Studio 9.0 ziehen, da das nur bis 1080p rendert.

      Ich bitte noch zu Beachten, das es sich bei meinem Bildmaterial um relativ gutmütiges handelt, das nicht sehr Komplex ist. Aber vielleicht ist das für den einen oder andren Interessant gewesen, den Vergleich zu begutachten.

      Auch wenn das hier nicht 100% zum Thread passt, zeigt es vielleicht doch, dass es sich lohnen kann, sich in die Sachen einzuarbeiten.

      Dank geht natürlich an De-M-oN für das Tutorial.

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von AsChilledkroete ()

    • Danke für deinen umfangreichen Post :)

      Leider ist der Bildhoster totale scheiße. Man kann die Bilder nicht in Vollbild angucken, nur das kleine Bild. Und wenn ich draufklicke auf das Bild kommt die Startseite von imageshack. Was ist bloß mit dem Hoster los?? Der regt mich so dermaßen auf damit...

      Wäre schön wenn man die Vergleiche auf 'nem Hoster hätte wo es direktlinks zum Bild sind.

      z.B. sehr empfehlenswert hier:

      bilder-hochladen.net/

      Der Server ist auch wenigstens schnell und nicht so quälend langsam wie imageshack.

      Ich denke, dass Vegas Movie Studio 9.0 und Lagarith, einen kleinen Konflikt, mit der Mehrkernunterstützung hatten/haben. Die Prozessorauslastung lag nämlich bei knapp 25% wären des Rendervorgangs, daher denke ich, dass der Wert nicht repräsentativ ist, sondern das in einem viertel der Zeit zu schaffen sei. Vielleicht hat jemand einen konstruktiven Tipp, der über das setzen der Mehrkernunterstützung im Codec hinaus geht


      In der Lagarith Konfiguration Multithreading anhaken ;)
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
    • De-M-oN schrieb:


      Leider ist der Bildhoster totale scheiße. Man kann die Bilder nicht in Vollbild angucken, nur das kleine Bild. Und wenn ich draufklicke auf das Bild kommt die Startseite von imageshack. Was ist bloß mit dem Hoster los?? Der regt mich so dermaßen auf damit...

      Wäre schön wenn man die Vergleiche auf 'nem Hoster hätte wo es direktlinks zum Bild sind.

      z.B. sehr empfehlenswert hier:

      bilder-hochladen.net/

      Der Server ist auch wenigstens schnell und nicht so quälend langsam wie imageshack.

      Hmm... bei mit kann ich eine Vollbildansicht bekommen. Ich werde die Bilder schnell beim vorgeschlagenen Hoster hochladen und oben zusätzlich verlinken. Falls Sie klein erscheinen die Vergleichsbilder sind nur 1280x720 groß.

      De-M-oN schrieb:


      Ich denke, dass Vegas Movie Studio 9.0 und Lagarith, einen kleinen Konflikt, mit der Mehrkernunterstützung hatten/haben. Die Prozessorauslastung lag nämlich bei knapp 25% wären des Rendervorgangs, daher denke ich, dass der Wert nicht repräsentativ ist, sondern das in einem viertel der Zeit zu schaffen sei. Vielleicht hat jemand einen konstruktiven Tipp, der über das setzen der Mehrkernunterstützung im Codec hinaus geht


      In der Lagarith Konfiguration Multithreading anhaken ;)

      Habe ich, ich weiß normalerweise was ich mache. ;)
      Mal gucken, ich bekomme das Programm schon überredet.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von AsChilledkroete ()

    • Geil wäre wenn du jetzt noch direkte Links zu den Bildern machst :)

      bilder-hochladen.net/files/big/i0nf-1.png
      und
      bilder-hochladen.net/files/big/i0nf-2.png


      Es gibt einfach kein Grund die Sachen vom Hoster mit laden zu lassen, wenn man nur das Bild sehen will ;)

      Ja die Unterschiede sind schon sehr signifikant sichtbar. War aber auch irgendwo vorrauszusehen, das dem Sony AVC 3000 kbit einfach nicht reichen werden :D
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

    • Moinsen,
      ich hab seit dem Update auf die Revision 2028 (direkt der core, also MeGUI selbst) folgendes Problem:
      Ich öffne - ganz wie gewohnt - den Avisynth Script Creator.
      Dort möchte ich meine Videodatei (1h, mit Lagarith Encodiert @ 2048x1152) importieren.

      Dann kommt folgendes Fenster:
      Link zum Bild

      Dort werden mir also 3 Wege angeboten, die Datei zu öffnen.
      Den One Click Encoder möchte ich ehrlich gesagt benutzen.
      Der File Indexer fährt mit FFMS, der aber nicht lagarithtauglich ist.
      Beim Öffnen via DirectSource kommt die Fehlermeldung, dass er die Datei nicht öffnen könne.

      Gäbe es eine andere Möglichkeit, die Datei mit meinem x264 Preset zu encodieren?

      Jedenfalls, schon mal ein Danke im vorraus.
      Gruß,
      UltraHelloWorld

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von UltraHelloWorld ()

    • Lagarith = AVISource, weißt ja auch. Und da musste dann hier DirectShowSource auswählen.

      File Indexer und Oneclick fallen hier flach.

      One Click wäre mit meinen neuen Presets die ich später mal posten werde sehr laienhaft tauglich (da super einfach) zu machen, aber leider hat man da nicht die Möglichkeit dem beizubringen, das er AVISource nehmen soll und NICHT File indexer.

      Beim Öffnen via DirectSource kommt die Fehlermeldung, dass er die Datei nicht öffnen könne.


      Doch musser aber über AVISource können.

      ggf. den Lagarith Codec nochmal drüber installieren ( lags.leetcode.net/codec.html )
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

    • Hm, ich bekomme - trotz Neuinstallation von Lagarith (mit anschließendem Reboot) - nachwievor die Meldung, dass das Format nicht unterstützt werde. Notfalls werd ich nochmals auf eine ältere Revision downgraden und dann eben nur x264, etc. updaten.
    • Das macht aber kein Sinn irgendwie :(

      Weil du hattest vorher ja auch AVISource benutzt oder nicht?

      Hast du vllt irgendn Codecpack o.ä. vor kurzem installiert gehabt?

      Wenn du dir manuell eine AVS Datei anlegst mit AVISource als decodierungsweg und diese dann mit MeGUI öffnest, geht das?
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
    • De-M-oN schrieb:



      Weil du hattest vorher ja auch AVISource benutzt oder nicht?

      Hast du vllt irgendn Codecpack o.ä. vor kurzem installiert gehabt?

      Wenn du dir manuell eine AVS Datei anlegst mit AVISource als decodierungsweg und diese dann mit MeGUI öffnest, geht das?


      Zum ersten Punkt: Jop, eigentlich hab ich meine Videos mit AVISource geöffnet.
      Zum zweiten Punkt: Neh, Codecpacks können mir gestohlen bleiben (musste mein ganzes System nau aufsetzen, da mir das meine ganze Codecliste zerschossen hat.

      Das mit dem manuellen Script anlegen hab ich noch nicht versucht.
      Ich werds probieren und anschließend reineditieren.

      EDIT: Hrmpf, über diese Methode funktionierts.
      Ich gehe jetzt mal ganz "frech" davon aus, dass es sich um einen eventuellen Bug handelt.

      Naja, ich benötige eh nur ein relativ kurzes Script.
      Von daher passt mir diese neue Methode eigentlich auch...

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von UltraHelloWorld ()

    • Kannste mir vllt mal den Scriptinhalt geben, das MeGUI erstellt, wenns zu dem Fehler kommt?
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
    • wow das ist ja mal richtig Katastrophe bei dir 8|

      DirectShowSource statt AVISource machter bei dir und convertfps hat da auch nichts verloren und die fpsrate spricht für sich.

      Ich versteh nicht, warum er bei dir kein AVISource nimmt. Bei mir macht er es ganz normal.

      Naja das versteh ich jetzt echt nicht ganz o.o

      Naja müsstest dann erstmal das Script manuell machen. Kannst ja ein Muster AVS anfertigen, dann brauchste da immer nur Videopfad aktualisieren^^

      Aber echt komisch. Vllt echt ein Bug, aber woher der rühren könnte ist mir jetzt gerad völlig unklar.


      Ehhhh moment mal, bei dem DirectShowSource Eintrag ist ja nicht mal der Pfad zum Video.

      Woher kommt das denn?

      Vllt Sonderzeichen im Video? Oder admingeschützter Ordner oder so? EDIT2: Offensichtlich nicht, wenn ich 1. Bild angucke. Extrem komisch. Oder mag er vllt die Leerzeichen nicht?
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von De-M-oN ()

    • Das mit den Leerzeichen hab ich noch nicht ausprobiert, ging aber vorher immer so.

      Jedenfalls, ich hab schon wieder ein Problem: Das encodierte Video (durch mein Script geöffnet) bricht nach ca. 7 Minuten aprupt ab.
      Dann erscheint auf dem Video nur mehr folgender Text:
      ultrahelloworld.lima-city.de/images/accessviolation.jpg

      Im Moment komm ich mir wirklich blöd vor O.o

      Jedenfalls, das Script sieht im Moment so aus:
      AVISource("G:\Fraps\RENDER SET 3.avi", audio=false).AssumeFPS(30.000)
      #deinterlace
      #crop
      #resize
      #denoise

      ConvertToYV12()


      Ich glaub, ich sollte die AVI mal auf ecentuelle Fehler checken...

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von UltraHelloWorld ()

    • Lagarith & VLC?

      Das ist wie Hund & Katze.

      Ein Wunder das es überhaupt auf ging.
      Aktuelle Projekte/Videos




      Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
      Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7