YouTube Video stellt nur grau dar

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • YouTube Video stellt nur grau dar

    Anzeige
    Hallo Leute, folgendes Problem:

    Ich lad ein MP4-/MKV-Video hoch (beides probiert) bei YouTube hoch, es kommt folgendes bei raus: Fehlervideo
    Vorgehensweise bisher:

    - Aufnahme mit Fraps (3.2.8 ), seit dem ich aufnehme noch nie verändert, klappte immer
    - Aufnahme der Stimme mit PanaX
    - Schneiden mit Sony Vegas Movie Studio 10 PE, in ein AVI-File mit Lagarith
    Einstellungen (auch schon vieles variiert):



    Das fertige AVI-File mit StaxRip und folgenden Einstellungen komprimieren:









    Hat jemand eine Idee, einen Tipp woran es liegen kann? Mir geht das Latein aus, hab schon unzählige Einstellungen ausprobiert, sowohl in Lagarith als auch beim Komprimieren. Danke für jede Hilfe.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von RednaxelaLP ()

  • Mir wurde der Lagarith-Codec speziell in diesem Forum ans Herz gelegt und überall anders auch, also muss es doch an etwas anderem liegen. Ich probier gleich HuffYUV aber keine Ahnung, wäre nett wenn sich einige der Lagarith-Befürworter zu Wort melden würden. Habe Windows 7 x64, falls das eine Rolle spielen sollte.
  • Lagarith ist ein super Codec und extremst weit verbreitet. Wäre eigentlich Recht komisch wenn's daran liegen würde. Für die finale Encodierung könntest du's mal mit einem anderen Programm wie RipBot oder MeGUI versuchen. Bei ersterem bin ich mir 100%ig sicher, dass es sich mit Lagarith auch versteht.

    e: Hoppla den Post davor überlesen, dann ist mein Vorschlag ja nicht allzu dolle. :(

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von TukTukLP ()

  • Dreimal darfst du raten warum das x264 Preset bei mir den Namen De-M-oN trägt ;) Ich hab auch gehofft dass er da etwas weiß, denn die Anweisungen es auf diese Weise zu machen stammen auch direkt von ihm.

    Irgendwas haut hier nicht mehr richtig hin, habs grad mal mit Sony YUV Codec gerendert und wieder durch StaxRip / MeGUI gejagt und trotzdem das selbe Problem. Ich schau mal ob es irgendwelche Probleme mit meinem Fraps Codec oder so gibt, weil langsam gehen mir echt die Ideen aus.

    Ich hab mal spaßeshalber eins meiner neuen Deus Ex Aufnahmen gerendert und was ist? Kein Problem festzustellen mit Lagarith etc. 8|
    Ich dreh hier durch. Ich probiers gleich nochmal mit einer neuen Monkey Island Aufnahme..
    Neue Monkey Island Aufnahme gemacht, gerendert wie oben, komprimiert wie oben, hochgeladen, und es funktioniert alles wie es soll? Ich werd bekloppt. Naja, wenns so bleibt ist ja alles gut. Wenn eine vollwertige Aufnahme nacher oben ist und funktioniert ist das Thema hier beendet.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von RednaxelaLP ()

  • Mit MeGUI encodieren, mein Preset nehmen.

    Muxen mit MKVMergeGUI (ist in MKVToolnix enthalten.
    In MKVMerges' Optionen unbedingt den Haken setzen für "Kopfdatenkompression standardmäßig ausgeschalten".

    Hilft das noch nicht, probiere:

    FFVideoSource, statt AVISource. (Kann sein, das du dafür erst ffdshow installieren musst (eines der SVN builds nehmen)

    Wenn das der Fall ist dürfte MeGUI automatisch auch FFVideoSource als Decodierungsweg wählen. (wirst du im AVS Script Creator unter dem Reiter script sehen.)

    Lagarith kann leider FFVideoSource nicht decodieren. HuffYUV 2.1.1 kann er aber.


    Dieses Problem hatte AltF4Games und auch jemand anders und bei beiden konnte es so gelöst werden.

    Und du hast MeGUI 2006? Oder ein älteres?


    Zum Lagarith:

    Du kannst Nullframes anhaken. Bringt bessere Kompression.

    RGB Farbton nur dann benutzen, wenn du auch wirklich RGB Material als Quelle hast - Das ist bei Fraps Video nicht der Fall, wenn du den Lossless RGB Haken nicht drin hast. Fehlt der Haken im Fraps, nimmt Fraps in YUY2 auf. x264 wird auf YV12 Farbton setzen. Vermieden werden sollte bei einem non-RGB Farbbereich auf RGB zu konvertieren und dann auch nochmal wieder zurück auf non-RGB. Sind unnötige Farbbereichkonvertierungen, die weiteren Farbinfoverlust mit sich führen.
    Fraps sollte auch auf 3.4.2 geupdatet werden. Es hat sich viel getan in der Zeit. Es macht kein Sinn auf eine alte Version zu bleiben, sofern mans nicht muss wegen einem Spiel oder so.

    Generell ist MKV ohne Headerkompression für Youtubes Encoder eh kompatibler als MP4. (auch wenn Youtube seine Videos in einen MP4 Container steckt, mag es trotzdem MKV ohne Kopfdatenkompression irgendwie lieber)
    MKV ist eh der bessere Container. Unterstützt mehr Audioformate. Ich würde hier OGG Vorbis @ Qualität ab 6,0 nehmen.


    Deine Toneinstellung aufm Screenshot mit 96 kbit/s AAC ist übrigens extrem low.

    So eine verdammt niedrige Tonbitrate sollte man nicht nehmen.

    192 kbit/s könnens ruhig mindestens sein. Zumal Youtube eh nochmal wieder encodiert macht es das nur noch schlimmer.
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • An alle die hier was wegen Lagarith sagen: ist doch vollkommen egal, das er wandelt doch sowieso nochmal in einen Lossy Codec um, wenn dann liegts an x.264 (oder Youtube, wenn das Video auf der Platte keine Fehler anzeigt)

    Ich würds einfach nochmal probieren..anscheinend macht Youtube Probleme.

    Nimm mal .mkv als Container und stell Vorbis bei Ton ein, hat bei mir eine bessere Qualität :)
    www.google.de
  • Ja, die kleinen neuen Testaufnahmen machen keine Macken aber das volle Video neu aufgenommen dann wiederum schon.. ich krieg langsam echt das große Brechen.
    Das Problem ist, ich kriegs mit Vegas gar nicht erst hin in HuffYUV zu encoden. Es schmiert immer ab wenn ich versuche über "ffdshow video codec" und dann HuffYUV auswähle und versuche zu rendern schmiert alles ab.

    Aber na gut, ich hab grad mal mein bereits fertiges MP4 nochmal mit diesem MKVMergeGUI gemuxt und bin grad dabei es hochzuladen, er zeigt mir sogar beim Hochladen schon die Bearbeitungsvorschau. Und die Bilder die dort erscheinen sehen soweit in Ordnung aus. Wenn es jetzt endlich mal klappt mach ich ein Bier auf.
  • Ich denke das es klappen wird :)

    MP4 = oft fehlerhaft auf YT
    MKV @ ohne Headerkompression = ging bei mir bisher IMMER :)

    HuffYUV im ffdshow ist alt.

    neuron2.net/www.math.berkeley.edu/benrg/huffyuv-2.1.1.zip

    ist der aktuelle. HuffYUV ist aber nur 32bit und bei Vista / Win7 etwas umständlich zu installieren.

    Bei diesen eine Admin Eingabeaufforderung öffnen und diesen Befehl:

    rundll32 C:\Windows\SysWOW64\setupapi.dll,InstallHinfSection DefaultInstall 0 C:\Path\To\huffyuv.inf

    Bei WinXP ist es ein bloßer Rechtsklick auf die .inf und -> Installieren.

    Ich schätze aber, das HuffYUV bei einem 64bit Videoprogramm nicht auftauchen wird.
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • Wow, genial, man nimmt ein und die selbe Datei, muxt sie in ein MKV ohne Headerdateien und schon funktioniert es? Ich werd verrückt. Aber hauptsache es geht, ich danke dir vielmals De-M-oN ! :)

    Echt verrückt. Die nächsten Male werde ich immer nur drauf achten die Soundkompression besser zu gestalten und dann ist alles geschafft :)

    Hach.