Fraps, Audioverzögerungen!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Fraps, Audioverzögerungen!

    Anzeige
    Hi Leute,
    ich wollte mal fragen, ob es eine Möglichkeit gibt, das folgende Problem zu beheben.
    Und zwar, wenn ich mit Fraps aufnehme, dann entstehen nach und nach (nach gewissen Abständen) immer größere Soundabstände von meiner Stimme zu dem Gamesound. Z.B. Meine Stimme kommt 2Sec. später. (Dieser Abstand wird immer größer).

    MfG Max
  • Man ich versteh es einfach nicht. Wieso haben so viele Probleme mit asynchronem Sound mit Fraps 8|

    Ich hab das Problem noch nie gehabt, seit Version 2 schon nicht. Ich versteh das einfach nicht. Ich würde wirklich gern mal wissen, was bei euch da hakt und warums bei mir noch nie war. Das muss doch ein Grund dafür geben.. ?(

    Ansonsten meine Standardtipps, die manchen geholfen hat:

    -> Antivirus & Firewall auf jeden Fall aus.
    -> Andere HDD & CPU belastende Programme aus.
    -> FPS Zahl in Fraps so wählen, das sie während der Aufnahme auch konstant gehalten werden kann, sprich wenn man zb 40fps einstellt, sollte er auch auf die 40fps laufen und nicht nur 25 erreichen, oder gar schwanken. Das erhöht Fraps die Schwierigkeit Synchronität zu bewahren. Testweise auch mal mit Lock Framerate Haken. (Dann begrenzt dich Fraps mit Aufnahmefps = Spielfps.) Ohne Lock FPS Haken gibt dir Fraps ausgehend von 30fps Aufnahmefps 60 fps zum Spielen, wenn der PC noch mehr als 60 fps packt während der Aufnahme, bei mehr als 90, 90 usw. Diese Vorgehensweise macht Fraps ja auch nicht ohne Grund. Daher kann man sich ja denken, das schwankende FPS Rate suboptimal ist.

    Wenn aber die obigen Punkte alle nicht zutreffen, versteh ich nicht woher die Asynchronität herrührt...
    Aktuelle Projekte/Videos


  • Anzeige
    Meine Vermutung ist das es an Fraps liegt, seit der 3.4.x Version hat bei mir jeder Frapsvideoaufnahme einen Boing-effekt im Sound, bzw werden Frames weggelasen von Frapscodec...
    Das äußert, sich so, das wenn zB am Anfang der Sound synchron ist, nach 5 Sekunden der Sound um 1 sekunde hinterherhinkt, dann nach 10 sekunden ist es wieder Synchron und nach weiteren 10 sekunden hinkt der Sound wieder um 1-2 Sekunden hinterher, immer so weiter, bis es sich ach einigen Minuten eigepegelt hat und irgendwann synchron läuft, wie schon gesagt nervig dabei ist, das Fraps dabei immer wieder Framesdrops hat (Bilder weglässt)
    ist nervig weil die Soundspur dann nicht synchron mit der Bildspur ist.... nachdem ich aber wieder die gute alte Fraps 3.2.3 installiert habe ist der Effekt aber wieder weg gewesen (habe schon länger den Verdacht das Fraps 3.2.3 die beste, bisher erschienene, Version ist)
    Ganz Großes Kino von Fraps, viele gute neue Funktionen und Performance verbesserungen, aber der Codec selbst macht seine Arbeit nicht mehr wirklich gut (einige Leute berichten ja auch von vermehrten Bildfehlern, aber bis auf die Frames-Verluste hab ich nichts davon bemerkt)

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von maestrocool ()

  • ja ich nehme eine ältere version zum aufnhemen und zwar die 3.2.6 (^^)
    was mir aber aufgefallen ist als ich mit meinem Grabber aufgenommen habe auch so eine asynchronität da war mit meiner stimme von audacity! Dann habe ich von Klinke zu USB gewächselt und es funktioniert wieder!
    Es ist wirklich komisch und auch wenn das mit meinem Grabber nicht ganz so zum thema passt wechsle doch einfach dein Headseat "Modus"
    Eine Frage speicherst du inzwischen was also renderst du ein Video oder lädst eins hoch?
    Wenn ja das vermeiden während der aufnahme
  • @De-M-oN
    Ich kann mir nur Vorstellen das es am System liegt, ich benutze durchgehend AMD und du die Intel nVidia kombination, aber wie schon gesagt mit der 3.2 serie 0 Probleme, mit der 3.4.x Serie leichte Soundschwankungen und ausgelassene Frames die bei der 3.2.x Serie nicht auftraten... (oder es liegt vielleicht daran , weil die meisten deiner Spiele auf OpenGL-Basis sind, ka )
    warum das so ist weiß ich nicht, aber an der Leistungsfähigkeit meines Systems kann es nicht liegen, denn der Taskmanager sagt mir das noch gut Luft ist nach oben und meine Festplatte ist ebenfalls ausreichend schnell (separate SSD für Windows, separate SSD für die Spiele und separate Festplatte für die Aufnahme)
    einzig die Frapsversionen machen einen Unterschied bei mir und bis jetzt bin ich mit der 3.2.3 am besten gefahren, klar hatte Fraps hin und wieder kleine Probleme, wie zb als sich der Mauszeiger in (alten DX) Spielen nicht bewegen ließ, aber diese Probleme haben sie ja schnell gefixt.
    Man kann also sagen, Probleme gab es schon (die du nur nicht bemerkt hast, weil sie bei dir nicht aufgetreten sind) aber im großen Ganzen lief Fraps immer ganz in Ordnung, nur seit der 3.4.x Serie stimmt das Frapsvideo in sich, nicht mehr so richtig, ansonsten kann ich mir diese Geschwindigkeitsschwankungen nicht erklären.
    Ist genauso wie bei Youtube, die einen kämpfen jeden Tag gegen die Youtube-Bugs, und die anderen bemerken sie erst gar nicht (weil sie zB die Funktionen gar nicht benutzen).