Technisches Problemchen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Technisches Problemchen

    Anzeige
    Oh gott, jetzt stelle ich hier auch mal ne frage auf die die Leute sicher nur antworten wie dumm ich sei, dass ich sie Stelle =D
    Aber egal, wat sein muss muss sein, AAAAALSO:

    Ich als absoluter Computer Nichts-Wisser benötige Hilfe und zwar dreht es sich um folgendes:
    Ich habe einen eigentlich für Emulatoren geeigneten PC, wie ja aber sicherlich einige von euch wissen tut mein PC allerdings nie, was ich wil, will sagen:
    Es laggt, wenn ich NES/SNES/GB(C/A) Spiele Emuliere und versuche das aufzunehmen =D
    Und nein, damit meine ich keine framedropps von so... 3-4 Frames, sondern eher von so... 30 - 40 Frames...

    Jetzt mal zu ein paar evtl relevanten technischen Details meines Rechners:
    Motherboard: ASUS M2N-MX SE Plus
    CPU: AMD Athlon 64 X2 Dual Core Processor 6000+ (3110 MHz)
    GraKa: GForce 9400 GT (512 MB)
    Arbeitsspeicher: 2 GB Ram
    Operating System: Windows 7

    joa =D
    Braucht ihr mehr? Sagt mir Bescheid ^^;

    Tja, ich bin mir der Tatsache bewusst, dass mein PC nicht der beste ist, im Grunde sogar schrott vor dem Herrn, allerdings wüsste ich schon gerne, warum meine Kollegen mit weit aus schlechteren PC's trotzdem Videoaufnahmen und sogar das eine oder andere Hoch-Qualitäts-Spiel problemlos spielen können und ich hier mit meinem Rechner sitze und mit Laggs in Emulatoren zu kämpfen habe ^-^;
    Wäre genial, wenn mir jemand von euch sagen könnte, was zur Hölle ich hier falsch mache, zumal mir das Geld für nen neuen Rechner fehlt und die Zeit fehlt mir das Geld für nen neuen Rechner durch z.B. Arbeiten gehen zu verdienen...

    Danke im Vorraus, Exit

    Oh, PS:
    Alle Treiber sind auf dem neusten Stand, allerdings nur was die von Microsoft gestellten Treiber angeht (Windows7 Automatische Treibersuche)
  • RE: Technisches Problemchen

    Du bist ja dumm, dass du diese Frage stellst ;)
    Nein, Spaß beiseite.

    Hast du vielleicht viele Programme im Hintergrund laufen? Die beim Start von Windows mit starten und dann Rechenleistung ziehen? Das wäre jetzt die einzige Erklärung die mir einfiele. Weil hardwaremäßig sollte der Rechner komplett ausreichen.
  • RE: Technisches Problemchen

    daic0r schrieb:


    Du bist ja dumm, dass du diese Frage stellst ;)
    Nein, Spaß beiseite.

    Hast du vielleicht viele Programme im Hintergrund laufen? Die beim Start von Windows mit starten und dann Rechenleistung ziehen? Das wäre jetzt die einzige Erklärung die mir einfiele. Weil hardwaremäßig sollte der Rechner komplett ausreichen.


    Nein, ich hab nix im Autostart, das einzige was da immer und immer wieder auftaucht mach ich jeden Tag mittels Taskmanager (Prozess beenden) aus, weil sich das dumme Ding sonst nicht beenden lässt (Es ließe sich schon, aber es mag irgendwie nicht auf den "Close" button reagieren >-> ) und ich bisher noch nicht rausgefunden habe, wo Honestech es installiert hat, damit ich dieses Ding komplett entfernen kann (im Software Manager stehts nml auch nicht drinn =D)
  • RE: Technisches Problemchen

    Anzeige
    Hatte letztens das Problem mit meinem GBA-Emulator und die Lösung dazu ist eigenartig, aber effektiv:

    Du darfst keine beliebige Fenstergröße wählen, also solltest du nur Standardgrößen nutzen, die man in den Emulator-Optionen hat.
    Beim GBA-Emu z.B. auf Optionen -> Video -> Window-size 1x/2x/3x usw.

    Weiß nicht wie es bei anderen Emulatoren aussieht, aber vielleicht klappt es ja auch da ;)
  • RE: Technisches Problemchen

    Lusy schrieb:


    Hatte letztens das Problem mit meinem GBA-Emulator und die Lösung dazu ist eigenartig, aber effektiv:

    Du darfst keine beliebige Fenstergröße wählen, also solltest du nur Standardgrößen nutzen, die man in den Emulator-Optionen hat.
    Beim GBA-Emu z.B. auf Optionen -> Video -> Window-size 1x/2x/3x usw.

    Weiß nicht wie es bei anderen Emulatoren aussieht, aber vielleicht klappt es ja auch da ;)


    Hrm... sollte ich mal testen =D
    Ich wähle allerdings keine beliebige Fenstergrößen, sondern ne Vorgegebene, vom Emulator, nml die 640x480 FS Einstellung des VBA's ^.^;
    Und weder da noch beim ZSNES oder SNES9X scheint es wirklich großartigen einfluss zu haben... ich dachte eigentlich ja, dass das Frameskipping was bringen würde (Emu läuft derzeit mi 20 FPS) aber leider hat mir Zelda bewiesen, dass auch das nicht klappt, denn bei Zelda 3 (GBA) gibts auch framedrops von bis zu 5 Frames (Bei meiner 20 FPS einstellung hieße dette, dass hier ein viertel der eigentlichen darstellungsleistung flöten ging, oder seh ich dette falsch?)
  • RE: Technisches Problemchen

    Hmm, viel weiß ich dann auch nicht weiter, aber das mit den Frameskips ist korrekt, 1/4 geht dann flöten ;D

    Das Einzige was mir grad noch einfällt ist halt die FPS-Einstellung bei Fraps, solltest du Fraps zum Aufnehmen nutze. Da habe ich persönlich auf 60 FPS gestellt und habe keine Lags/FPS-Einbrüche mehr.
    Vielleicht klappt ja das ^^
  • RE: Technisches Problemchen

    Hast du das neueste NET.Framework auf deinem PC? Weiß zwar nicht ob das was hilft, aber sollte auf jedenfall installiert sein.
    Vielleicht probierst du auch mal ältere Versionen des Emulators aus, es kann nämlich sein das die Rom mit Version XY nicht so ganz zurecht kommt.
    Wenns nicht hilft: Lad dir mal ne Testversion von Fraps und nimm mit 60 fps auf. Bei mir ist es mit diesen Einstellungen immer laggfrei. In der Testversion kannst du zwar nur 30 Sekunden aufnehmen, aber die Performance kann man dabei ja ganz ordentlich testen.
  • RE: Technisches Problemchen

    Ich wundere mich auch immer darüber, dass scheinbar viele LPer mit sporadischen Lags nur während der Aufnahme zu kämpfen haben. Die habe ich nämlich entweder dauernd während der Aufnahme (weil Spiel + Aufnahme generell zuviel für den Rechner sind) oder garnicht... aber sporadisch? Hatte ich nie 0_o

    Mögliche Gründe:
    • Spiele beanspruchen die CPU unterschiedlich - wird sie zu stark beansprucht, hängt die Aufnahme. Das trifft aber für Gewöhnlich nicht auf emulierte Spiele zu, insofern keine gültige Erklärung...
    • Die Festplatte ist zu stark fragmentiert: Während das Video geschrieben wird, muss die Festplatte dauernd ihren Lesekopf neu ausrichten -> Verzögerung beim Schreiben, Verzögerung beim Spiel. Abhilfe: Defragmentieren (z.B. mit Defraggler) oder das Video auf einer nicht fragmentierten Partition (oder gleich andere Festplatte, siehe nächster Punkt) speichern.
    • Die Platte ist generell zu langsam, um gleichzeitig Videos aufzunehmen und Spieldaten zu lesen. Abhilfe: Die Videodaten auf einer zweiten Festplatte (nicht Partition!) abspeichern. Ich z.B. weise Fraps immer an, auf meiner externen USB-Platte aufzunehmen, was bei mir Ladezeiten extremst verkürzt hat.
    • Falls das Spiel nur einen Prozessorkern nutzt und man mindestens einen DualCore sein Eigen nennt: Es bringt auch was, wenn das Videoaufnahmeprogramm und das Spiel CPU-mäßig voneinander "getrennt" sind (z.B. Spiel benutzt CPU-Kern 1, Aufnahmeprogramm benutzt CPU-Kern 2). Lässt sich z.B., nachdem Spiel/Aufnahmeprogramm gestartet wurde, im Taskmanager (Registerreiter "Prozesse" -> Rechtsklick auf Prozess -> "Zugehörigkeit festlegen...") einstellen.
    • Generelle Tipps: Alle Hintergrundprogramme, die stören könnten, vorübergehend ausschalten (v.a. Virenscanner können das System stark belasten, da manche z.B. dauernd das aufgenommene Video komplett nach Viren durchsuchen, weil die Videodatei dauernd neu geschrieben wird - generell gilt das für alle Programme, die Updates im Hintergrund ausführen können, also z.B. auch Steam und Java...)
    • Falls man die aufgenommenen Bilder im Aufnahmeprogramm einstellen kann: Stellt es unbedingt auf 30 Bilder pro Sekunde! Ich weiß nicht warum alle Welt meint, mit 60 Bildern pro Sekunde aufnehmen zu müssen. Bereits 30 reichen für flüssige Aufnahmen problemlos aus - selbst Youtube rechnet eure Videos nach dem Hochladen automatisch auf 30 Bilder/Sekunde herunter, also bringen 60 euch überhaupt nichts, wenn ihr Youtube nutzt.
    Ich pers. habe einen DualCore 2x 3 GHz, dafür 4 GB RAM, und konnte nie irgendwelche Probleme während der Aufnahme feststellen. Im Gegenteil nehme ich meist sogar von Vornherein mit einem "X.264-lossless"-Codec auf, der die CPU noch zusätzlich beansprucht, und habe keinerlei Probleme mit Framedrops (unter ZSNES mit 640x480 mit SnagIt-Codecaufnahme, oder "Trackmania United Forever" mit Fraps-Aufnahme und alles in höchsten Details gestellt).
  • RE: Technisches Problemchen

    War bestimmt nicht leicht, die Frage ins Forum zu posten, wah? :P

    BTT
    @eZehicheL
    an .NET framework könnte es vielleicht liegen. Bezweifle es aber sehr.
    Mit Fraps kann man nur Vollbildspiele aufzeichnen, D.h. keine Emulatoren oder Flash-Games.

    @Exi
    Versuche erstmal Astorek86 Tipps zu untersuchen, weil was er da sagt ist in keinster Weise falsch.
    Ach und bist du sicher, dass es die GeForce 9400 GX in deinem Computer verbaut ist?
    Ich kenne die nämlich nicht und google auch nicht -.-'
    Meinst du vielleicht die GeForce 9400 GT?
  • RE: Technisches Problemchen

    Also wenn man alle Tipps von Astorek86 befolgt sollte es wirklich keine Probleme geben ;)
    Jedoch muss ich bei der FPS-Zahl widersprechen.
    Fraps verringert bei mir, sobald ich anfange aufzunehmen, die Rate um ein paar Frames wenn ich auf 30Bilder/sek stelle ._. kA warum, vielleicht ist es ja nur bei mir so.

    @ pelgro: Man kann sehr wohl Emulator-Spiele mit Fraps aufnehmen ;) Mach ich ja auch immer. Man muss nur ein paar Einstellungen durchführen, die Fraps zeigen, dass es sich um ein 3d-Spiel handelt ^^
  • RE: Technisches Problemchen

    pelgro schrieb:


    War bestimmt nicht leicht, die Frage ins Forum zu posten, wah? :P

    BTT
    @eZehicheL
    an .NET framework könnte es vielleicht liegen. Bezweifle es aber sehr.
    Mit Fraps kann man nur Vollbildspiele aufzeichnen, D.h. keine Emulatoren oder Flash-Games.

    @Exi
    Versuche erstmal Astorek86 Tipps zu untersuchen, weil was er da sagt ist in keinster Weise falsch.
    Ach und bist du sicher, dass es die GeForce 9400 GX in deinem Computer verbaut ist?
    Ich kenne die nämlich nicht und google auch nicht -.-'
    Meinst du vielleicht die GeForce 9400 GT?


    Argh, mein fEhler, sorry, 9400 GT, ja ^.^;
    werd da smal eben ändern, scheiß halbdösende Tipperei... *zum ändern wusel*

    @ Ezehichel:
    Ich benutze Fraps bereits mit 120 FPS (Max) habe es bei 60 FPS versucht, mit 30 FPS, mit 50, mit 33, mit Knips und das hilft kein stück, selbiges gilt damit natürlich auch für Lusy =D

    @ Astorek:
    Ich könnte meine Externe Festplatte mal bemühen und werde das ausprobieren, zu den anderen sachen:
    Meine Festplatte IST defragmentiert, Ich habe (wie schonmal erwähnt) alles unnütze während einer Aufnahme IMMER abgeschaltet, nen Virenscanner habe ich nichmals (Schande über mich) und ich würde zu gerne mit 30 FPS aufnehmen, allerdings habe ich eine alte Frapsversion, die anders als die neuen dann das Spiel auf 30 FPS runterbremst, Resultat: Slowdowns und netterweise laggt es trotz allem noch (Ja, auch hier finden framedropps statt)

    Nochmal Speziell @ Pelgro:
    Wenn man keine Ahnung hat...
    Natürlich lassen sich Emulatoren etc mittels Hypercam Programmen (wie z.B. Fraps) aufnehmen!
    Solang die Oberfläche eine 3D Oberfläche ist(sorry für alle Fachpusemuckels da draußen, i do not have knowledge) nimmt Fraps den Emulator auf, und Flash Standalones kann unter der gleichen Vorraussetzung aufnehmen...

    Oh und noch additional:
    Ich würde ja gerne ältere Spiele mit Dingen wie Camtasia, oder Camstudio oder shitthefucktoberflächenrecordings(Patent beantragt) aufnehmen, allerdings unterstütz meine Onboardsoundkarte (Trot neusten treibern etc) keinen Stereomix, was es mir leider gottes unmöglich macht irgendwie IGS in die Aufnahmen zu bringen, ergo: Muss ich bei fraps (der Gamebremse) bleiben =S
  • RE: Technisches Problemchen

    @Exi und Lusy
    Sorry, dass ich mich geirrt habe. Ich habe gelsen, dass man mit Fraps nur Vollbildspiel / 3D Spiele aufnehmen kann.
    Ausserdem habe ich das auch nicht hinbekommen mit Fraps meinen Emulator aufzunehmen... und da fällt mir gerade ein, dass es ein Tut darüber gibt. Hier im Forum -.-' (********** ********)