Video in Desktopaufnahme nur schwarz

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Video in Desktopaufnahme nur schwarz

    Anzeige
    Hi Leute, habe folgendes Problem.

    Wenn ich den Desktop aufnehme (egal mit welchem Programm) und auf dem Desktop laüft ein Video (egal in welchem Player), dann ist in der Aufnahme die Fläche, wo das Video laufen sollte, einfach nur schwarz.

    Auch z.B. die Vorschau in Camtasia oder dem AVS Video Editor sind nicht da. Hat jemand eine Ahnung woran das liegt bzw. wie ich es wieder um/abstellen kann ? Bin da irgendwie gerade mit meinem Latein am Ende.

    BS: XP
    GRAKA: GTX560Ti
    PROZESSOR: Phenom II X4 965 Black Edition

    ...
    ◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆

    ◆ Meine Empfehlung: FarCry ◆ Laufendes Projekt: World of Tanks

    ◆ Meine Streams findet ihr auf der Gamerplattform: Hitbox.tv ◆



  • Bei den meisten Video-Player wird ein anderes Verfahren benutzt. Keine Ahnung wie und was da passiert, aber scheinbar ist der Player in einer bestimmten Farbe eingefärbt, die dann später durch das Video ausgetauscht wird.

    Als Beweis kannst du ja mal ein Screenshot von der Farbe machen, dann lässt du ein Video abspielen positionierst den Player so, dass sich das Video in der Bildvorschau überschneidet und schon kannst du das Video durch die Bildvorschau ansehen.

    Wenn du ein Video in deiner Aufnahme abspielen willst, empfehle ich dir, es im nachhinein hinein zu bearbeiten.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von LetsPlayES ()

  • An den Playern kann es eigentlich nicht liegen, da es bei jeglicher Darstellung von Videos passiert.

    Also auch bei den Videos die als Vorschau z.B. in Camtasia laufen. Ich hatte bei VLC auch schon alles durchprobiert.

    Egal was ich auf dem Desktop laufen habe, wenn ich es mit irgendeinem Desktopaufnahmeprogramm mit aufzeichne, ist es schwarz.

    Ich denke es könnte eine Einstellung bei der Grafikkarte sein. Nur weis ich weder welche, noch wo die ist.

    ...
    ◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆◆

    ◆ Meine Empfehlung: FarCry ◆ Laufendes Projekt: World of Tanks

    ◆ Meine Streams findet ihr auf der Gamerplattform: Hitbox.tv ◆



  • Anzeige
    Wie ich es schon oben beschrieben habe, liegt es daran, dass der Player in einer bestimmten Farbe eingefärbt ist und erst im nachhinein (von der Hardware oder so) die Farbe mit dem Video "überschrieben" wird. Der einzige Player den ich kenne, der nicht so arbeitet ist der Player von Youtube (oder jeder andere Flash-Videoplayer).

    Probier das mal:

    Öffne VLC und lass ein beliebiges Video laufen. (Dieses Experiment funktioniert nur mit VLC!)
    Nimm dann deinen Browser mit dem du diese Seite betrachtest und schiebe dieses Bild mit der speziellen Farbe, die von VLC benutzt wird über das Video, das hinter dem Browser noch weiterspielen soll.



    Das soll dann ungefähr so aussehen:



    Jetzt solltest du beobachten können, dass das Video durch das Bild mit der speziellen Farbe noch zu sehen sein wird.
    Das liegt an dem oben beschriebenen Ablauf der Darstellung.

    Ich kenne keinen Weg das umgehen zu können und empfehle dir immer noch das Video mit dem Videobearbeitungsprogramm deiner Wahl im nachhinein einzufügen.

    Edit: Mir ist gerade eingefallen, dass VLC auch die Option "DirectX-Desktophintergrund" hat. Diese Option macht nichts anderes, als den Desktophintergrund in die spezielle Farbe zu ändern.

    Das wichtige Stichwort was hier aber gefallen ist, ist "DirectX", woraus ich erschließe, dass hinter diesem Algorithmus DirectX steckt (welch komplexer Gedankensprung, ich weiß). Versuche mal Optionen zu DirectX zu finden!

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von LetsPlayES ()