Minecraft out of Memory

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Minecraft out of Memory

    Anzeige
    Hallo,
    erst mal ja ich weiss, dass dieses Thema schon duzende male durchgekaut worden ist, aber leider sind die alle im Archiv und ich kann drauf nicht mehr antworten. Mit dem was Google ausspuckt kann ich auch wenig anfangen bzw hab da schon rumprobiert. Also erst mal ich habe dieses out of memory Problem mittlerweile im 15 Sekunden takt, das raubt echt jeden nur erdenklichen Spielspass!! Es ist auch egal ob Einzel oder Multiplayer, ich mach dauernd Flugstunde -.- das was mir aufgefallen ist, wenn ich mich alleine ganz tief runtergrabe und unterirdisch baue habe ich das Problem nur ganz selten...bin ich aber an der viel bebauten Oberfläche hält es wie gesagt nur 15-30 Sekunden und ich übertreibe da jetzt nicht! Zu meinem System, ich hab Windows Vista Ultimate 64 Bit drauf und mein PC ist ein:

    AMD Athlon(tm) II X2 260 Processor 3,20 GHz
    4 GB RAM
    NVIDIA GeForce GTS 450 Grafikkarte

    welches für Minecraft alle mal ausreien sollte :evil:
    Da ich schon nachgeforscht habe und öfters gelesen habe, dass 64 Bit Systeme evtl für Probleme sorgen könnten habe ich eine BAT Datei erstellt mit folgendem Inhalt:

    Quellcode

    1. "C:\Program Files (x86)\Java\jre6\bin\javaw.exe" -Xmx1024M -Xms512M -jar "C:\Users\KamikazeLP\desktop\Minecraft.exe"

    was bei meinem Kumpel einwandfrei funktioniert hat...aber bei mir gibt es keinen Unterschied, es herrscht weiterhin fröhliches abstürzen -.- ach und was ich beinahe vergessen hätte, ich habe kein Texturenpack, keinen Skin und keinen Mod installiert, einfach nur Minecraft 1.1 gekauft und seit Anfang an (ca. 4 Wochen) dauernd Probleme, die aber wie mir scheint immer schlimmer werden ;(
    Ich hoffe ihr könnt mir da helfen!
    LG, KamikazeLP.
  • Hast du dein Minecraft irgendwie gemoddet oder ähnliches, wie Texture Packs oder ähnliches. Evtl kann es zu nem Memory Leak führen. und mach evtl mal in deiner Batch Datei unten drunter eine Zeile mit Pause, so erhältst du eine Fehler oder ähnliches hoffe ich, der evtl nen bisschen mehr Aussagen zu deinem Problem gibt.

    Ne alternative wäre beide Zahlen mal langsam hochzudrehen und zu schauen ab wo das Problem nicht mehr auftritt.
  • Och kollege ..
    du kannst deine exe nicht mit mehr über 'ne .bat starten.
    ich mach dazu nacher auch mal 'nen video tutorial. du brauchst die minecraft.jar für Linux usw.
    und die musst du dann mit MEHR ram (1 GB z.B.) starten. habe es selbst mal getestet.. mir 'ne .bat geschrieben, die minecraft 4 GB zuweist. erst mit der minecraft.exe probiert = minecraft hatte immer noch max 'nen GB ram .. dann die linus minecraft.jar genommen und minecraft hatte wirklich 4 GB zugewiesen ... video folgt

    €dit:
    Und wieso hast du 64 bit wenn du nur 4 GB ram hast??? :thumbdown:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Evolution ()

  • redw0lf schrieb:

    Hast du dein Minecraft irgendwie gemoddet oder ähnliches, wie Texture Packs oder ähnliches.


    KamikazeLP schrieb:

    ach und was ich beinahe vergessen hätte, ich habe kein Texturenpack, keinen Skin und keinen Mod installiert, einfach nur Minecraft 1.1 gekauft und seit Anfang an (ca. 4 Wochen) dauernd Probleme, die aber wie mir scheint immer schlimmer werden ;(


    Evolution schrieb:

    €dit:
    Und wieso hast du 64 bit wenn du nur 4 GB ram hast??? :thumbdown:


    Ääähh wieso? Was ist denn daran schlecht?

    LeChuckLP schrieb:


    ich hatte das Problem auch... aber es gibt eine recht einfache Lösung :
    minecraftforum.net/topic/9391…s-options-news/


    Das ist der Magic Launcher. Damit kann man ganz einfach Mods installieren oder auch Minecraft mehr Ram zuweisen.
    Ich kann es nur empfehlen da es die einfachste Methode ist.
    Ich hoffe das Hilft dir :D


    Werd ich auf jedenfall gleich mal ausprobieren :) danke!! :thumbup:

    Belarion schrieb:

    du hast die 32bit java-version und der kannst du nicht mehr ram zuweisen. brauchst also die 64-bit version. würd das zuweisen sonst eh über die systemsteuerung machen


    Wie kommst du da drauf? 8|
  • Evolution schrieb:


    Och kollege ..
    du kannst deine exe nicht mit mehr über 'ne .bat starten.
    ich mach dazu nacher auch mal 'nen video tutorial. du brauchst die minecraft.jar für Linux usw.

    Das stimmt doch gar nicht! o_O
    Das funktioniert, man braucht nicht die .jar. Es geht auch die .exe Version.
    Im Prinzip ist das nichts anderes, nur etwas anders verpackt als exe.
    Siehe meine bat:

    "C:\Program Files\Java\jre7\bin\javaw.exe" -Xmx2G -Xms2G -jar "C:\Users\Pax\desktop\Minecraft.exe"

    Und ja, Minecraft hat 2GB nun zugewiesen. ;)

    Evolution schrieb:


    Und wieso hast du 64 bit wenn du nur 4 GB ram hast??? :thumbdown:

    Wieso "nur"? Er hat alles richtig gemacht. Mit einem 32-Bit Betriebssystem hätte er die nicht voll nutzen können. Und ob ich jetzt einen halben Gigabyte mehr oder weniger nutzen kann macht in der Größenordnung noch einen Unterschied.
    Mal davon abgesehen, dass es langsam Zeit werden würde, dass die 32-Bitsysteme langsam mal verschwinden. ;)
    Außerdem ist das längst nicht der einzige Vorteil der x86-64 Architektur.



    Übrigens wäre auch mein Tipp, dir die aktuellste 64-Bit Javaversion zu installieren (die alte vorher deinstallieren). (Falls die nicht aktuell sein sollte).
    Danach kannst du entweder via .bat (mit größeren Zahlen wie zB 2G) oder per Systemsteuerung mehr RAM zuweisen.
    Probiere es doch mal ggf. mit aktualisierter Javaversion mit 2G zugewiesenem RAM - Verhalten noch da?
    Probiere mal testweise Optifine zu installieren - stellt sich eine Verbesserung ein? Habe da schon viele Wunder mit erlebt. ;)


    Liebe Grüße
    Paxnos

    *EDIT*
    Nachtrag:
    Du benutzt eine 32-Bit-Version von Java, das erkennt man am Programmpfad. -> "Program Files (x86)"
    Also meine Vorschläge: x64 Version laden, installieren und die Pfade und Werte der .bat anpassen. :)

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von Paxnos () aus folgendem Grund: Nachtrag

  • LeChuckLP schrieb:

    Hey
    ich hatte das Problem auch... aber es gibt eine recht einfache Lösung :
    minecraftforum.net/topic/93914…er-094-mods-options-news/


    Das ist der Magic Launcher. Damit kann man ganz einfach Mods installieren oder auch Minecraft mehr Ram zuweisen.
    Ich kann es nur empfehlen da es die einfachste Methode ist.
    Ich hoffe das Hilft dir :D

    mfg
    LeChuckLP


    Hey also dieser Launcher ist gut, ich hab jetzt die ganze Zeit ohne einen Lag oder einen Absturz gezockt =) danke für diesen super Tip!

    Paxnos schrieb:

    Übrigens wäre auch mein Tipp, dir die aktuellste 64-Bit Javaversion zu installieren (die alte vorher deinstallieren). (Falls die nicht aktuell sein sollte).
    Danach kannst du entweder via .bat (mit größeren Zahlen wie zB 2G) oder per Systemsteuerung mehr RAM zuweisen.
    Probiere es doch mal ggf. mit aktualisierter Javaversion mit 2G zugewiesenem RAM - Verhalten noch da?
    Probiere mal testweise Optifine zu installieren - stellt sich eine Verbesserung ein? Habe da schon viele Wunder mit erlebt. ;)


    Liebe Grüße
    Paxnos

    *EDIT*
    Nachtrag:
    Du benutzt eine 32-Bit-Version von Java, das erkennt man am Programmpfad. -> "Program Files (x86)"
    Also meine Vorschläge: x64 Version laden, installieren und die Pfade und Werte der .bat anpassen. :)


    Hey,
    oke ich hab die 64 Bit Java nun auch installiert und ich benutze jetzt erst mal diesen M;agic Launcher, aber ich werde mir trotzdem noch das mit der BAT Datei nochmal vorknüpfen, schon alleine zwecks der Neugier :D auch dir danke ich für deinen guten Rat, jetzt kann ich endlich Minecraft zocken ohne diese extrem nervigen Abstürze :)
    LG, KamikazeLP.
  • KamikazeLP schrieb:

    Hey,
    oke ich hab die 64 Bit Java nun auch installiert und ich benutze jetzt erst mal diesen M;agic Launcher, aber ich werde mir trotzdem noch das mit der BAT Datei nochmal vorknüpfen, schon alleine zwecks der Neugier :D auch dir danke ich für deinen guten Rat, jetzt kann ich endlich Minecraft zocken ohne diese extrem nervigen Abstürze :)
    LG, KamikazeLP.
    Dann mach ich hier mal zu.. Wenn noch Rückfragen aufkommen, oder ich anderwertig zu früh geclosed haben sollte, so genügt eine kleine PN.

    ~ CLOSED