Schlieren bei FPS-Änderung in Sony Vegas

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Schlieren bei FPS-Änderung in Sony Vegas

    Anzeige
    Langsam kotzt mich die ganze Sache einfach nur noch an (tolle Einleitung).
    Hab damals noch mit Sony Vegas final gerendert, allerdings bin ich auf MeGui umgestiegen, da ich bemerkt habe, dass Sony Vegas beim Ändern der FPS (das ursprüngliche Video hat zB 40 FPS, es wird mit 30 gerendert) "Schlieren" verursacht. Irgendein komisches Nachziehen.
    Hab dann am Anfang weil ich die Audio-und Videospuren zusammenfügen musste Sony Vegas zum Vorrendern benutzt, und habs dann am Ende mit 40 FPS gerendert. War natürlich viel größer...
    Jetzt wo es DxTory gibt (oder ich davon weiß) ist das nicht nötig. Allerdings kann man Montagen leider nicht mit MeGui machen, also hab ich jetzt mal seit... puh.. ich glaube 12-13 Stunden nonstop ein paar Clips bearbeitet. Allerdings vergaß ich dadurch die Sache mit den FPS ändern: Wenn ich also bei einem Event die Geschwindigkeit verändere (mit STRG + ziehen) [zB für Slowmotion], entsteht DASSELBE. Allerdings weiß ich von vielen Videoeditern die genau dasselbe machen und danach kein "schleifen" haben. Also, woran liegt das? Das ist dasselbe, als wenn ich von 40 auf 30 FPS ändere. Hat es allgemein etwas mit FPS zu tun? Sind dafür diese ominösen 29,777 FPS gebräuchlich? Passiert sowas bei 30 FPS? Kann ich mir eigentlich nicht vorstellen, allerdings weiß ich icht woran es liegen könnte.
    Jedenfalls sind die Videos so ungenießbar, war damals auch der Grund wieso ich mir so viel Arbeit gemacht habe, einfach unerträglich.
    Ist dafür "Twixtor" NOTWENDIG? Kann ja eig. nicht sein, kenn auch viele die das nicht haben. Damit macht man zwar irgendetwas geschwindigkeitsmäßiges, aber trotzdem zieht man das Event ja lang/oder kurz.

    Hier mal der Unterschied:
    youtube.com/watch?v=GC7jVe2C3P…9AA96D13&feature=view_all
    Gut erkennbar bei ruckartigen Bewegungen, zB 13:53. Einfach auf die Ränder der Waffe gucken. Und auch danach, beim Schießen. (von 45 auf 40 FPS gerendert)

    youtube.com/watch?v=7mRP-yb7liE&feature=mfu_in_order&list=UL
    Hier ist alles normal. (40 auf 40)

    Und hier im direkten Vergleich:
    youtube.com/watch?v=eiowO_SDcpI
    Bis 0:15 ist dieses Schlieren, aufgrund von veränderter Laufgeschwindigkeit.
    Danach ist es ganz normal, unveränderte Geschwindigkeit.

    Und da frag ich euch: muss das echt sein? Ist ja klar dass es nicht so flüssig läuft wenn es verlangsamt ist weil es ja nur 30 FPS sind, aber trotzdem dürfte dieses Schlieren nicht sein.
    Bitte um Hilfe, und entschuldige mich schonmal für meinen Text, bin über 35 h wach. (Übrigens ist es Sony Vegas Pro 10)

    lg
  • Das Problem hatte ich selber mit Vegas noch nie... wenn ich dich recht verstehe, hast du Qualitätseinbußen bei allen Videos, die du mit Vegas renderst. Hast du mal versucht, dir das Video einfach lossless ausgeben zu lassen (Lagarith, z.B.) und dann mit MeGUI zu rendern?
    Habe gerade selbst mal einen Clip beschleunigt und mit Lagarith Codec ausgeben lassen, und ich habe das Problem nicht. Folgende Einstellungen hab ich benutzt:


    Vielleicht bringt dir das ja was.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Lumarion ()

  • Allgemein gesagt sind FPS eine hakelige Sache bei der Videobearbeitung. Je nach Programm kann es durchaus sein, dass bei Änderung der FPS-Zahl auch mal was verloren geht, ist leider nicht unüblich (sogar im professionellen Bereich). Deswegen ist es klug, sich auf eine einzige FPS-Zahl zu einigen - YouTube gibt dir 30 (und wirklich 30, nicht etwa 29.97), also würde ich das auch durch die Bank weg überall sonst so machen. Spiel, Aufnahmeprogramm, Bearbeitungsprogramm, Renderprogramm. Je mehr Programme sich auf die 30 FPS einigen, desto weniger Probleme wirst du bekommen. :)
  • Anzeige
    Achso, und noch eine kleine Zusatzinfo: Wenn man wirklich das Vergnügen hat, FPS-Änderungen machen zu müssen, dann bietet es sich an, möglichst eine Verdopplung oder Halbierung zu nehmen. Von 45 auf 40 Frames runterrechnen sieht nicht nur doof aus, sondern ergibt auch nicht sonderlich viel Sinn, denke ich. Von 60 auf 30 (oder vergleichbar) dann schon eher. ;)
  • Nein, ihr habt es nicht verstanden. Vielleicht habe ich mich zu schlecht ausgedrückt.
    Ich rendere IMMER lossless mit dem Lagarith, dort treten ja die Probleme auf. In MeGui kann man FPS changen. Zum Beispiel von 40 auf 30, und man muss nicht mit Qualitätseinbußen leben. In Sony Vegas habe ich damals auch von 40 auf 30 gerendert, damit die Datei nicht so groß wurde. Dank DxTory brauch ich das ja jetzt auch nicht mehr, kann in 30 FPS aufnehmen.
    Allerdings gehts mir jetzt um SlowMotion, bzw. FastMotion. Man kann ein Event in Sony Vegas langsamer oder schneller laufen lassen, in dem man STRG gedrückt hält und den Rand von einem Event in eine Richtung zieht. Diese Methode ist für Montagen unerlässlich.
    Doch genau dabei entsteht dieses Schlieren, siehe mein Video. Und hierfür bräuchte ich eine Fehlerbehebung.

    @Julien
    Das mit dem halbieren und so ist ja garnicht relevant, mir gehts ja um keine FPS Änderungen, ich wollte damit nur sagen, dass es mir dort auch auffällt. Und um zB 50 % die Geschwindigkeit reduzieren ist definitiv nicht möglich, muss ja leider auch auf die Musik abgepasst werden.
    Trotzdem danke für eure Bemühungen.

    EDIT:
    Weiß eigentlich jemand wofür dieses "Interleave" in den Rendereinstellungen zuständig ist? Ich habe ja das Gefühl, dass man das dadurch beheben kann, hab allerdings auch nach vermehrten Tests nichts rausgefunden.

    lg

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von tatschmeedown ()

  • tatschmeedown schrieb:

    Allerdings gehts mir jetzt um SlowMotion, bzw. FastMotion. Man kann ein Event in Sony Vegas langsamer oder schneller laufen lassen, in dem man STRG gedrückt hält und den Rand von einem Event in eine Richtung zieht. Diese Methode ist für Montagen unerlässlich.
    Doch genau dabei entsteht dieses Schlieren, siehe mein Video. Und hierfür bräuchte ich eine Fehlerbehebung.

    Achso, du willst ein Video einfach nur langsamer oder schneller ablaufen lassen. ;) Jetzt hab ich - glaub ich - verstanden.
    Ich kenn mich zwar mit Vegas nicht aus, aber es klingt so, als würden die fehlenden Frames interpoliert werden, und da kann es je nach Software natürlich zu seltsamen Effekten kommen, weil das Programm sich praktisch ein Bild ausdenken muss. Passiert bei Twixtor leider auch öfters als man denkt.
  • Jo, genau das meine ich. Was gibts da noch zu beachten um das zu verbessern? Und wie ist das mit Twixtor gemeint. Ist ja auch als Plugin für Sony Vegas zu verwenden, und die Einstellungen wirken sich ja nur auf die Verlangsamung aus, den Clip muss man trotzdem länger ziehen. Bei mir stürzt Twixtor immer nur ab.

    @De-M-oN, der gerade diesen Thread liest

    Ja, das damals bei Mafia 2 war, und weshalb Du mir das mit MeGui erklärt hast! =)

    lg

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von tatschmeedown ()

  • tatschmeedown schrieb:

    Weiß eigentlich jemand wofür dieses "Interleave" in den Rendereinstellungen zuständig ist? Ich habe ja das Gefühl, dass man das dadurch beheben kann, hab allerdings auch nach vermehrten Tests nichts rausgefunden.


    Ohne Interleave wird die Videospur am Anfang der Datei geschrieben und die Tonspur am Ende der Datei.

    Suboptimal fürs Abspielen, weil so der HDD Lesekopf ständig große Sprünge machen muss.
    Fürs Encodieren aber besser, da so Audio und Video nicht rausgefriemelt werden muss. Sprich wenn MeGUI Audio encodieren soll, welcher im Video steckt, dann kann MeGUI den Ton um die 10x schneller encodieren, wenn kein Interleave genutzt wurde.

    Es gibt unterschiedliche FPS Rate Änderungen.

    Bei Avisynth ist es so das:

    ChangeFPS die Frames löscht
    ConvertFPS staucht sie. Sieht dann bissl aus wie Motion Blur. Bei dieser Methode werden halt die Frames nicht gelöscht. Dürfte wohl der ähnliche Effekt sein, den du gerade mit Vegas hast.
    Aktuelle Projekte/Videos


  • tatschmeedown schrieb:

    Was gibts da noch zu beachten um das zu verbessern? Und wie ist das mit Twixtor gemeint.

    Gute Frage, wie gesagt kenn ich mich mit Vegas leider nicht aus. Da wird dir wohl jemand anders mit mehr Vegas-Erfahrung helfen müssen.
    Ansonsten hab ich das mit Twixtor so gemeint: Auch mit Twixtor (der quasi-Referenz für SlowMotion) gibt es immer wieder komische Effekte bei Geschwindigkeitsänderungen, das ist einfach manchmal nicht zu vermeiden. Die Software kann so gut sein wie sie will, aber Inhalte berechnen, die faktisch nicht vorhanden sind, führt halt nicht immer zum richtigen Ergebnis. ;)
  • Was soll man dann bei Interleave einstellen? Nichts pro Sekunde oder pro Frame? Einfach Standard, so wies auch bei Luma ist?

    Oh my fucking god!? Ich hab grad durch Zufall "Resampling deaktiviert", über die Eigenschaften eines Events= Und siehe da, es taucht nicht mehr auf. Allerdings ist das scheinbar das was De-M-oN sagt: es läuft jetzt ruckeliger da keine Frames hinzugefügt werden. Würde trotzdem eher das nehmen, muss das testen wie es dann bei ner 60 FPS Aufnahme ist.
    Standardmäßig ist "Intelligentes Resampling" eingestellt, dann kann mans noch normal aktivieren oder deaktivieren. Werde damit noch ein bisschen rumprobieren.

    Übrigens tritt das Problem bei 0:59 nicht auf, wobei es sehr viel langsamer ist. Bei 0:30, wo ausversehen etwas an der Geschwindigkeit verändert wurde, ist es total am Schleifen)
    youtube.com/watch?v=9RMePfKW5eI

    lg
  • tatschmeedown schrieb:

    Oh my fucking god!? Ich hab grad durch Zufall "Resampling deaktiviert", über die Eigenschaften eines Events= Und siehe da, es taucht nicht mehr auf. Allerdings ist das scheinbar das was De-M-oN sagt: es läuft jetzt ruckeliger da keine Frames hinzugefügt werden.

    Ja, das klingt so, als würden jetzt keine Frames mehr interpoliert werden. ;) Klar ruckelt es dann ein bisschen, aber das kann eine gute Zeitlupe durchaus vertragen.
  • tatschmeedown schrieb:

    Was soll man dann bei Interleave einstellen? Nichts pro Sekunde oder pro Frame? Einfach Standard, so wies auch bei Luma ist?


    Den Haken weg machen.

    Achso naturgemäß wird dann 0 - 50% das Video encodiert und 51 - 100% Audio. Das heißt 51 - 100% wird außergewöhnlich schnell fertig werden.

    Nicht das du dich beschwerst, nun würde das Encodieren doppelt so lange brauchen :P
    Aktuelle Projekte/Videos


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()