DxTory - Kein Mikrophonton

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • DxTory - Kein Mikrophonton

    Anzeige
    Hallo Leute ! :)

    Ich hab ein mehr oder weniger großes Problem mit DxTory. Ich bin zwar im Ganzen sehr angetan von DxTory, doch will es einfach nicht mein Mikro mit aufnehmen. Alles andere packt es, aber das nicht. Ich kann das Mikro zwar auswählen als zusätzliche Audiospur, aber wenn ich das Video dann abspiele hört man nichts. Also nichts ist nicht ganz richtig, denn wenn ich die Audiospuren trenne, dann mal die einzeln Mirkospur abspiele und ganz laut dreh, dann hört man ein "Fiepen". Ich hab ein Asus Motherboard und nutze deren integrierte Soundkarte SoundMAX Integrated Digital HD Audio mit zugehörigem Treiber. Mein OS ist Windows 7.
    Ich würde ungern diese unglaublich praktische Funktion von DxTory außer Acht lassen und mit Audacity o.ä. separat aufnehmen.
    Ich hoffe jemand kann mir da helfen :)

    MfG Hakuho
  • Anzeige
    Das habe ich mit DxTory in Verbindung mit Lagarith auch ... wird wohl eine Codecsache sein.

    Im Windowsmediaplayer hört man beide Spuren, in TMPGEnc "fehlt" dann plötzlich die Zweite Spur und wird auch nicht mitgerendert. Ich habe mir jetzt einfach damit geholfen das ich mit VirtualDub die Spur als Wave rausziehe und in das jeweilige Renderprogramm packe. Die Spur ist also tatsächlich aufgenommen und fehlt nicht.

    Lade dir mal VirtualDub runter: virtualdub.sourceforge.net/

    Unter "Audio -> Source Audio" kannst du dann die entsprechende Spur auswählen und mit "File -> Save Wav" speichern.

    Hoffe das hilft weiter.
  • Haha, stimmt. Ist mir noch aufgefallen ... so gehts auch! :)

    VirtualDub kann aber nie schaden ;)

    Der VLC Player scheint mir eine Voraussetzung zu sein.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von FlinteInsKorn ()

  • Also wie in meinem ersten Beitrag angedeutet hab ich das schon versucht mit dem Extrahieren und alles auf 5 verschieden Playern versucht abzuspielen. Ebenso wollte ich Lagarith benutzen, hab aber auch mal testweise den Standardcodec von DxTory genommen: NIchts hat sich verändert. Auch die KHz- sowie Bit-Rate der Audiospur hab ich variiert, ohne ersichtlichen Erfolg.

    EDIT: Achja und das mit dem Rechtsklick -> Extract Audio Stream kommt von DxTory selbst.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Hakuhō ()

  • Schon klar, nur das mit dem "fiepen" nach dem extrahieren kannte ich auch. Das trat nach dem extrahieren mit VirtualDub und jetzt halt mit VLC nicht mehr auf. Wenn Du es also noch nicht mit einem der beiden Möglichkeiten probiert hast, würde sich das lohnen.

    Gut, mit "Extract Audio" gehts also auch nicht. Dann bin ich raus, wird was anderes sein.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von FlinteInsKorn ()

  • Also bei mir war das so, dass ich bei dem Schaltfeld 'Audio' was anderes umstellen musste: Bei dem ersten Bereich ('Audio Settings') musste ich auf das grüne '+' drücken, dann auf die erschienene '2' und dann beim zweiten Bereich ('Audio Device') auf die Schaltfläche und auf 'Microphone (...)' klicken, lautstärke einstellen, fertig!

    (Ähnlich wie AwesomeTeeParty schon sagte)

    Versuchs mal.
  • Also habe jetzt Virtual Dub, einen weiteren Video- sowie Audiocodec und abschließen nochmal die Ausgangseinstellungen mit PCM Mono probiert. Leider ohne Erfolg.

    Trotzdem vielen Dank für die Antworten :)
    Dann werde ich mich wohl oder übel ins DxTory Forum begeben müssen. Falls jemand jedoch noch eine Idee hat würde es mich freuen wenn er sie hier schreiben könnte :)

    MfG Hakuho

    Edit: @BrAlexLP Das hatte ich gleich zu Anfang gemacht. Und ich habe auch mein Mikro ausgewählt ;)

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Hakuhō ()

  • FlinteInsKorn schrieb:

    Der VLC Player scheint mir eine Voraussetzung zu sein.


    Ganz bestimmt nicht, und es gibt auch besseren Player als VLC ..

    Rechtsklick auf die .avi und
    "Extract Audio Stream"

    Bin mir aber nciht sicher ob man dafür
    den VLC braucht oder nicht ..


    Dafür brauchst du DXTory. 8o

    Versuche einmal bei den Audiospuren
    MPEG Layer-3 Codec (320 kBit/s, 48 000 Hz, Stereo


    MP3 sollte nicht als Aufnahmecodec verwendet werden. PCM ist da so oder so am kompatibelsten.
    Außerdem reichen 44.1 khz völlig.

    und bei der Videospur den
    Helix I420 YUV Codec


    Was hat Video mit dem Ton zu tun ? :P

    Mach mal eine Environment info:



    Nicht wundern das es da noch 2.0.110 ist. Der Screenshot ist älter.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von De-M-oN ()

  • So hier also die Environment Information:

    Spoiler anzeigen

    [Dxtory]
    Version: 2.0.111
    UID: 93806d3a-f896-4a18-8438-779c25577544

    [Dxtory Files]
    InstallPath: E:\Program Files (x86)\Dxtory Software\Dxtory2.0
    AudioStreamSplitter.exe: FileVersion: 1.0.0.0 SHA1: f2f729dc20a4f399704e99beeca855e85e5b9286
    AVIFix.exe: FileVersion: 2.0.0.3 SHA1: 9c418e2ef475ce5c13e22f2e4bae24a13e8b5cb4
    AVIMux.exe: FileVersion: 2.0.0.3 SHA1: b7d714051302a9081450775d625ffbda7a6ed637
    AVIMuxCore.dll: FileVersion: 2.0.0.3 SHA1: 77f91e5cbdb6516492937b09e8779fbfce339ad0
    Dxtory.exe: FileVersion: 2.0.0.111 SHA1: 78703acc281d534e24b5fb1931ff8cc20373c054
    Dxtory64.exe: FileVersion: 1.0.0.60 SHA1: 14e3f06e6f2afb2dcb8dec2813586253fc58d86b
    DxtoryAudioHelper.dll: FileVersion: 1.0.0.79 SHA1: 1e11c70e2f744fe9fcb95402c955d14f3d9503ce
    DxtoryCore.dll: FileVersion: 2.0.0.111 SHA1: 4425e37d7eb3a26208f4e4e0c6f817c59b30008d
    DxtoryCore64.dll: FileVersion: 2.0.0.111 SHA1: bbfbfb9b37055355e0e917bd0a1997ab43882e00
    DxtoryHK.dll: FileVersion: 2.0.0.102 SHA1: 1620be1abce75026c938346b03f2e7db9f58cd97
    DxtoryHK64.dll: FileVersion: 2.0.0.102 SHA1: 51cbeb0535a665bf303fea368d1b0d725cc8d6f9
    DxtoryMM.dll: FileVersion: 1.0.0.1 SHA1: 82eeaf2ec6ddd70f887ea5e20a80be718600b230
    DxtoryMM64.dll: FileVersion: 1.0.0.1 SHA1: c142da021338ef96d13dc82c70c6ba2a443d1108
    DxtoryVideo.dll: FileVersion: 2.0.0.97 SHA1: b9c1ff13a061e189affef9ae37f5ae142450b189
    DxtoryVideo64.dll: FileVersion: 2.0.0.97 SHA1: 497ef3f62908d7a1f9362fc347198b900fc7c131
    DxtoryVideoSetting.exe: FileVersion: 2.0.0.97 SHA1: 44c8cfaea0f5592e35793048d6ba080b37283530
    LicReg.exe: FileVersion: 2.0.0.1 SHA1: 451bbe61d429d549ff37f21a96cbd1e83a19d016
    RawCapConv.exe: FileVersion: 2.0.0.94 SHA1: d248bdbd934517d5b7f3d2e3b47ddf523303e84f
    RCStream.dll: FileVersion: 1.0.0.76 SHA1: 31266452f142cd7c856384945ffc410b2c9c8be9
    unins000.exe: FileVersion: 51.1052.0.0 SHA1: bc3fdf5ca301bdcda59fdc8102c437f31db3af18
    UpdateChecker.exe: FileVersion: 2.0.0.0 SHA1: 221bd3663f4393b368ebf74d1a892f9379ddbe44

    [System Information]
    CPU: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
    CPU Instruction Set: MMX SSE SSE2 SSE3 SSSE3 SSE4.1
    OS: Microsoft Windows 7 Enterprise x64
    OSVersion: 6.1.7601
    OSLanguage: 1031
    ServicePack: Service Pack 1
    Memory0: BANK0 2,147,483,648 bytes
    Memory1: BANK1 1,073,741,824 bytes
    Memory2: BANK2 2,147,483,648 bytes
    Memory3: BANK3 1,073,741,824 bytes
    TotalMemory: 6,442,450,944 bytes
    Total Physical Memory: 6,441,525,248 bytes
    Available Physical Memory: 4,160,413,696 bytes
    Total Page File: 12,881,154,048 bytes
    Available Page File: 8,997,187,584 bytes
    Total Virtual Memory: 2,147,352,576 bytes
    Available Virtual Memory: 1,750,171,648 bytes
    PerformanceCounterFrequency: 2935166 (0x2CC97E)
    VideoCard: AMD Radeon HD 6450 Memory: 1,073,741,824 Processor: ATI display adapter (0x6779) DriverVer: 8.930.0.0 DriverDate: 2011-12-05 01-00-00
    Display0: 1280x1024 32bits 60Hz
    SoundDevice: AMD High Definition Audio Device Manufacturer: Advanced Micro Devices
    SoundDevice: SoundMAX Integrated Digital HD Audio Manufacturer: Analog Devices

    [Audio Device]
    SPDIF-Schnittstelle (SoundMAX Integrated Digital HD Audio) - CoreAudioOut
    Lautsprecher (SoundMAX Integrated Digital HD Audio) - CoreAudioOut
    Mikrofon (SoundMAX Integrated Digital HD Audio) - CoreAudioIn, Volume 100
    Eingang (SoundMAX Integrated Digital HD Audio) - CoreAudioIn, Volume 100

    [Video Codec]
    Dxtory Video Codec FCC:xtor
    Cinepak Codec von Radius FCC:cvid
    DivX 6.8.5 Codec (2 Logical CPUs) FCC:divx
    DivX 6.8.5 YV12 Decoder FCC:yv12
    ffdshow Video Codec FCC:ffds
    Fraps Video Decompressor FCC:fps1
    Indeo® Video 5.10 FCC:iv50
    Intel IYUV Codec FCC:i420
    Intel IYUV Codec FCC:iyuv
    Lagarith Lossless Codec FCC:lags
    Microsoft RLE FCC:mrle
    Microsoft Video 1 FCC:msvc
    Microsoft Windows Media Video 9 FCC:wmv3
    VMnc v2 FCC:vmnc
    VP60® Simple Profile FCC:vp60
    VP61® Advanced Profile FCC:vp61
    VP61® Advanced Profile FCC:vp62
    Xvid MPEG-4 Codec FCC:xvid

    [Audio Codec]
    Microsoft IMA ADPCM
    Microsoft CCITT G.711
    Microsoft GSM 6.10
    MS-ADPCM
    DivX ;) Audio
    LAME MP3
    PCM
    IEEE Float

    [License Information]
    License: Registered
    Expire: Unlimited
    LicVerify: 4c4ec8fc08b438833de5a20e946e3de2f826bc90

    [Additional Information]
    Dxtory_log.txt: Empty
    ErrorLog.txt: Available Size=534

    ======================================================================

    [Profile]
    Name: Default
    Path:

    [Overlay]
    Option: Left Top VidoeFPS WriteFileFPS RecordState
    Color: Sleep FF00FF00, Active FFFF0000, Movie FF00FF00, ScreenShot FF00FF00

    [Folder]
    x E:\LP Speed: 0MB/sec Free: 186,891,870,208 Total: 358,087,528,448 Format: NTFS
    SSFolder: E:\LP

    [HotKey]
    MovieCapture: + (ZEHNERTASTATUR) (0x0000004E)
    ScreenShotSingle: - (ZEHNERTASTATUR) (0x0000004A)
    ScreenShotRepeat: None
    ScreenShotAuto: None
    ToggleStatus: None
    MovieCaptureFrame: None
    ScreenShotCaptureFrame: None

    [Movie]
    Clipping:
    ClipMargin: 0,0,0,0
    ClipSize: 0,0
    Scaling: Percent 100% 0x0
    Codec: Lagarith Lossless Codec, Quality 10000, KeyFrameRate 15, DataRate 0
    FrameRate: 30
    Output: File AVI
    Option: IncludeCursor

    [Audio0]
    Enabled: True
    Device: Lautsprecher (SoundMAX Integrated Digital HD Audio)
    Codec: PCM
    Format: PCM 44100 Hz, 16 bit, Stereo

    [Audio1]
    Enabled: True
    Device: Mikrofon (SoundMAX Integrated Digital HD Audio)
    Codec: PCM
    Format: PCM 44100 Hz, 16 bit, Mono

    [ScreenShot]
    Clipping:
    ClipMargin: 0,0,0,0
    ClipSize: 0,0
    Scaling: Percent 100% 0x0
    HighSpeedLimit: 0
    RepeatInterval: 1000
    Format: PNG
    JpegQuality: 100
    Option:

    [Advanced]
    Option:
    ThreadCount: 2
    LimitedFPS: False
    FPSLimit: 60

    ======================================================================
    VerifyHash: 88eafbd6883dee9b2ec65c011d8599e8bea63342

    Was kann man aus der Info denn so rauslesen? ;)

    MfG Hakuho
  • Divx Decoder Paket deinstallieren.

    Divx Decoder Paket will die Decodierung von AVI, MP4 und MKV Dateien übernehmen. Die Decoder vom Divx taugen aber nicht wirklich.
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • YESSS! Ich habs hingekriegt! :)
    Komischerweise muss ich einfach das Mikro als erste Tonspur festlegen und dann klappts. Zwar hör ich dann, wenn ich die Originaldatei abspiele den Ingamesound nicht aber wenn ich die Audiospuren dann extrahiere gehts. Keine Ahnung warum das so ist, aber Hauptsache es funktioniert :)


    Das Codecpacket hab ich jetzt auch deinstalliert. Vielen vielen dank für den Tipp Demon! :) Jetzt sehen meine Videos auch nicht mehr so über kontrastiert aus wenn ich sie mal mit WMP oder so abspiele. Gibt es denn ein Codecpacket, welches ich stattdessen nehmen sollte oder kann ichs einfach beim Standard belassen?

    Und noch ne Frage: Ich meine hier im Forum gelesen zu haben, dass beim Rendern der x264 besser wäre als der normale h264. Wenn dem so ist, würde ich ihn gern nutzen, allerdings möchte ich auch bei Premiere Pro bleiben, das hat den Codec aber nicht :( Gibt es eine Möglichkeit den Codec in Premiere Pro einzubinden?


    MfG Hakuho
  • Das sollte ohne dem Codeczeug nun eig. auch mit Tonspur 2=Stimme gehen.

    Wie gesagt. Divx und Codecpacks = no-go. Niemals sowas installieren.

    Als Player würd ich den MPC-HC nehmen + Haali Renderer.(Beim Setup den Haken aus Associate MKV and MP4 to WMP entfernen)

    Bei MPC-HCs Optionen dann unter Ausgabe den Renderer auf Haali Renderer anpunkten.

    Wenn du Premiere behalten willst:

    debugmode.com/frameserver/

    Als Exportformat wählste den Debugmode Frameserver aus, stellst den Ton auf PCM 44.1khz,16bit,Stereo.
    Dann speicherst du, dann kommt das Frameserverfenster, dort wählst du dann YUY2 aus und klickst auf Next. Dann öffnet sich ein weiteres Fenster. Du lässt beide Fenster offen und dann kannste mit x264 die AVI vom Frameserver encoden lassen. Wenn x264 fertig kannste die beiden Frameserver schließen.

    Als GUI Frontend für x264 empfehle ich MeGUI -> [ Video-Tutorial ] MeGUI -- x264 - bester Encoder, beste Videoqualität auf Youtube ;-)
    Aktuelle Projekte/Videos




    Seit etlichen Monaten komplett veraltete Signatur, wie ihr sicherlich schon bemerkt habt. Habe mittlerweile mehr als 4 Projekte, weshalb die Signatur leider momentan gesprengt ist xD
    Notdürftig die Liste was aktuell läuft: Unreal | Complex DooM (LPT) | DooM 2016 | Need For Speed III: Hot Pursuit | Dirt Rally | Dirt 4 | WRC 7
  • Also leider kann der MPC anscheinend meine Videos nicht flüssig darstellen. Die Audiospur läuft aber das Video bleibt im Prinzip am Anfang stehen.

    Den Frameserver hab ich auch installiert, aber es sieht so aus als würde er nichts rendern. Hat ne .avi Datei angefangen, steht bei 0% zeigt keine Festplattenaktivität.
    Wozu ich dann, falls das mit dem Frameserver funktioniert, MeGui noch brach, hab ich nicht ganz verstanden ;)

    MfG Hakuho