Handbreake - Bild und Ton asyncron

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Handbreake - Bild und Ton asyncron

    Anzeige
    Hallo, ich möchte demnächst mit meinem Kumpel zusammen ein LP machen, das erste überhaupt. Also habe ich gegoogelt, um zu erfahren, was ich dazu brauche und wie das ganze funktioniert.

    Erstmal bin ich jetzt am testen, damit später dann alles klappt. Zur Aufnahme benutze ich Dxtory. Nach viel lesen und Videos ansehen (Youtube) war ich der Meinung, das Dxtory besser ist (sein könnte) als Fraps.

    Die meisten Anleitungen haben die selben Einstellungen verwendet, so das ich diese übernommen habe. Den Ton haben wir erstmal außen vor gelassen (Mic), wichtig war erstmal eine saubere Aufnahme des Videos.

    In Dxtory benutze ich folgende Video-Einstellungen:

    Codec: Lagarith Lossless Codec
    Framrate: 30 fps
    Output: File Output
    File Format: AVI
    Scaling: Size 1280x768

    Um es kurz zu machen, die Aufnahme (56min) klappte super. Keine Probleme wärend des spielens, auch die Aufnahme selber ist Top, Bildqulität ist super, Bild und Ton (Ingamesound) sind bis zur letzten Sekunde völlig syncron.

    Natürlich ist die Aufnahme (33,7 GB) für YT zu groß. Später sollen das 15 oder 20 Minuten Parts werden. Zum Rendern benutze ich Handbreake. Laut Beschreibung hier im Forum ist dies die einfachste Methode, einfach bei Preset 'Normal' auswählen und nichts weiter einstellen, ideal für Anfänger. Das habe ich dann auch so gemacht. Die Größe war dann ok, das Bild fast gleich gut wie das original Video. Nur ein Problem vermasselte das gute Ergebnis. Bild und Ton waren asyncron. Um es genau zu spezifizieren, am Anfang ist es syncron und zum Ende hin erst asyncron. So in der Mitte ist es ca 1 Sekunde und am Ende dann ca 3 Sekunden.

    Meine Frage jetzt, woran liegt das? Wie kann ich das verhindern? Oder sollte ich gleich eine andere Software zum Rendern nehmen?
  • ich nehme an, du meinst Handbrake.

    wusste gar nich, dass inzwischen da überhaupt lagarith geht. 8|
    warum hast du size nich auf 1280x720? das wäre 16:9

    ist es nur im player asynchron oder auch auf youtube? vielleicht liegt es am player.
    vlc ist zB nicht so toll, da empfiehlt sich media player cassic + haali eher.

    wenn du bereit bist, wie du im lezzten satz angedeutet hast, die software zu ändern, würde ich dir aber auch zu megui raten. ist ebenfalls kostenlos.
    allerdings nur, wenn das video auf youtube ebenfalls asynchron ist und die fehlerbehebung sich als nicht so einfach gestaltet.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sam ()

  • sam schrieb:

    ich nehme an, du meinst Handbrake.


    Jo, meine ich... da hab ich mich vertan ;)

    sam schrieb:

    wusste gar nich, dass inzwischen da überhaupt lagarith geht. 8|


    War bei mir in der Version schon drinne, mußte ich nicht per Hand nachinstallieren.

    sam schrieb:

    warum hast du size nich auf 1280x720? das wäre 16:9


    Jo, hab ja 16:9 Monitor. Für YouTube reicht aber 720p, daher hab ich das gleich so eingestellt. Normal hab ich Desktopauflösung 1080p. Das Spiel (Borderlands) selber läuft bei mir aber im Downsampling mit 2880x1620px, das ergibt eine sichtbare Qualitätssteigerung im Bild.

    sam schrieb:

    ist es nur im player asynchron oder auch auf youtube? vielleicht liegt es am player. vlc ist zB nicht so toll, da empfiehlt sich media player cassic + haali eher.


    Hab das nicht hochgeladen, da das Video nur zum Test ist. Das LP folgt später erst. Angeschaut habe ich beide Videos (das Dxtory Video und das Handbrake Video) mit dem KMPlayer. Dxtory Video ist sync, das Handbrake Video ist async.

    sam schrieb:

    wenn du bereit bist, wie du im lezzten satz angedeutet hast, die software zu ändern, würde ich dir aber auch zu megui raten. ist ebenfalls kostenlos. allerdings nur, wenn das video auf youtube ebenfalls asynchron ist und die fehlerbehebung sich als nicht so einfach gestaltet.


    Danke für den Tipp, ich werde erstmal den Tipp von DerET versuchen:

    DerET schrieb:

    Stell bei Audio mal testweise auf "Auto Passthru". Irgendwie hat einer der Handbrake Soundencoder seit einigen Versionen 'nen Knacks und es entsteht diese Asynchronität.


    Ich probiere das mal und melde mich dann wieder.

    Nachtrag 16:50 Uhr: So, habe das Video nochmal mit der Audio Einstellung "Auto Passthru" durchlaufen lassen. Leider wurde das Problem nicht behoben, das Video ist immer noch aysnc. Ich werd mal schaun ob es hier eine Anleitung für 'megui' gibt und es damit mal versuchen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Hexinator ()

  • Ich hab das gerenderte Video mit KMP, MPC-HC (ob der Haali benutzt, bin ich überfragt) und mit VLC (extra dafür installiert) angesehen, bei allen dreien kommt der async Fehler, der zum Ende hin immer größer wird. Zudem hab ich das File über meine Mediabox (Asus) am TV geschaut, genau das selbe. Das original Dxtory File lief auf den 3 PC Playern sync. Auf der Mediabox ging es garnicht, wahrscheinlich wird der Codec nicht unterstützt.

    Ich versuch das jetzt mal mit der MeGUI Anleitung hier im Board. Da mußte ich mich erstmal per Video durch die Einstellungen kämpfen. Mal schauen wie das wird, er ist schon am rendern. Bei Handbrake war die Qualität top, mal schaun ob die jetzt hier auch so gut ist und vor allem... ist das jetzt syncron!?
  • So, MeGUI ist fertig mit rendern. Das wichtigste vorweg, der Ton ist syncron *freu*.

    Das bild ist im MeGUI Video etwas weicher als bei dem Handbrake Video, das war etwas schärfer bzw kontrastreicher. Beide Videos haben aber eine Top Bildqualität.

    Nun habe ich das Video als MKV gerendert, mit OGG als Ton, so wie in der Anleitung vorgeschlagen. Die HD Videos auf YouTube haben aber alle MP4 als Container mit AAC als Audio drinne. Nur rein zum Verständnis, weil ich da ungenügende Kenntnisse von der Materie habe, wäre es da nicht besser bzw sinnvoller, gleich ein MP4 Video mit AAC Ton zu erstellen? Wandelt YouTube das Video nach dem hochladen dann nochmal um? Wenn ja, ergibt das am Ende nicht einen Qualitätsverlust? Wahrscheinlich denke ich gerade völlig verkehrt ?(
  • Hexinator schrieb:

    wäre es da nicht besser bzw sinnvoller, gleich ein MP4 Video mit AAC Ton zu erstellen? Wandelt YouTube das Video nach dem hochladen dann nochmal um? Wenn ja, ergibt das am Ende nicht einen Qualitätsverlust?

    Nein, MKV-Container ist schon in Ordnung. Das verändert übrigens nichts an der Qualität. Ja, YouTube rendert komplett neu, und ja, du verlierst dadurch wieder ein bisschen Qualität, also lieber dafür sorgen, dass das Material, das du hochlädst, sehr gut aussieht und somit eine gute Basis zum Weiterbearbeiten darstellt. :)
    Und Glückwunsch, dass es mit MeGUI geklappt hat. Dann hast du ja jetzt das optimale Werkzeug gefunden.
  • Julien schrieb:


    Und Glückwunsch, dass es mit MeGUI geklappt hat. Dann hast du ja jetzt das optimale Werkzeug gefunden.


    Jo... Danke erstmal für eure Hilfe. Eine Frage hätte ich aber noch. Das Cutten des Videos auf z.B. 15 Minuten, macht man das beeser vor dem rendern oder hinterher?

    Ich werd mal ein 10 Minuten Stück rausschneiden und hochladen, nur zum Test. Ich gehe davon aus, das ich eigene hochgeladene Videos auch wieder löschen kann...
  • Ich habe jetzt ein 15 Minuten Stück zum Test auf YT hochgeladen. Bei einem direkten Vergleich zwischen dem original Video und dem Youtube Video, kommt das Youtube Video geringfügig schlechter davon. Das Bild ist etwas unschärfer, aber nicht viel.

    Eventuell kann mal einer was zur Qualität sagen (720p)... ist das so ok? Ich persöhnlich habe schon schlechtere Qualität bei 720p Borderlands Videos gesehen.

    Link: youtube.com/watch?v=-S2i0LmcL9k

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Hexinator ()

  • Abgesehen von der VideoQualität die man sich durchaus ansehen kann empfinde ich den sound als extream leise.. ich habe kaum die effekte gehört, aber ich meine evt auch ne stimme gehört zu haben die dann aber arg leise sei muss sogar noch leiser als der ingamesound...
    Alle Aktuelle & Beendete Projekte von mir sind in meinem Profil zu finden


    Website: In Planung ...|... Youtube: CruelDaemonLP ...|... Steam: CruelDaemonLP
  • Kurz zu Erklärung, wir haben das hier bei mir in der Bude im Coop über LAN gespielt. Mein Kumpel hat garkein Mic am PC, ich habe eins dranne, war aber deaktiviert. Normal sollten garkeine Stimmen zu hören sein. Der Ingamesound ist sicher eine Einstellungssache. Beim spielen selber war der Sound laut genug. Um ehrlich zu sein, dem Sound habe ich bei der Testaufnahme keinerlei Bedeutung zukommen lassen.

    Beim Test ging es hauptsächlich darum zu sehen, ob die Aufnahme beim spielen selber stört (tut sie nicht), wie das mit dem verkleinern (rendern) funktioniert und wie das auf Youtube ausschaut. Beim späteren LP ist sein Kumpel dann auch wieder mit seinem PC bei sich zu Hause und wir werden uns dann über Skype verständigen. Dann machen wir neue Probeaufnahmen, wobei besonders auf den Ton geachtet wird.
  • Das ist eine wirklich gute Frage. So groß ist der Unterschied jetzt nicht im Vergleich zum original Video. Natürlich könnte ich das ganze in 1080p aufnehmen. Da stellt sich dann erstmal die Frage, kommt mein Spiel dann ist ruckeln? Ok, das könnte man testen.

    Das gerenderte File wird dann sicher eine ganze Menge größer werden. Das heißt, mehr bzw länger hochladen. Nächste Frage wäre dann, ist der Unterschied bei Youtube zwischen 1080p und 720p wirklich so gravierend, das sich der Mehraufwand lohnt?

    Wenn ich mir ein LP ansehe, hab ich 2 Möglichkeiten. Ich schaue es am PC. Wenn dann dort 1080p und 720p angeboten werden, schaue ich in 720p, da ich bei meinem 24" Moni keinen großen Unterschied sehen kann. Aber in der Regel mache ich mir die Mühe und lade das ganze LP auf meinem Rechner runter und schaue es dann über meine Asus Box am PC. Find ich viel schöner vom Sessel aus. Hier ist es aber genau das selbe, ich sauge dann, falls beides angeboten wird, lieber die 720p Version. Ein ganzes LP hab ich so schneller unten. Und am 32" TV wird das Bild auf 1080p (per Box) hochscaliert. Da sehe ich dann im Vergleich zum echten 1080p Video auch kaum einen Unterschied.

    Ich vermute mal, das der größte Teil der sehenden User sich auch mit 720p begnügt. Damit habe ich mir die Frage eigentlich schon beantwortet. Eventuell könnte man beim rendern über MeGUI noch an den Einstellungen drehen, um so ein noch besseres 720p Bild zu bekommen. Da ich da aber Null Ahnung von habe, lasse ich das lieber :D